Ticket #2776 (closed Bug: invalid)

Opened 6 years ago

Last modified 3 years ago

Window "jumps" and does not submit when submit button clicked (IE)

Reported by: gmarshall Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6
Keywords: IE Cc: nicholas@…

Description

Bug appeared in 2.6.3 (not present in earlier versions) and continues through SVN.

Only occurs on pages that have a significant amount of content between the FCKeditor window, and the submit button of the form they both belong to.

To reproduce:

  • In IE6/IE7 only:
  • Create a test page, with many lines of content between FCKeditor window and submit button (or see example: http://garydev.nfshost.com/fcktest.php)
  • Click anywhere in the FCKeditor content window
  • Use scroll bar to scroll down to submit button, making sure "focus" is still on FCKeditor window
  • Click submit button
  • Form does not submit, and window jumps back to FCKeditor window

Notes:

  • Bug disappears in "quirks" mode
  • If focus is not in FCKeditor window, bug does not occur
  • If you use any method but the scroll bar to scroll, bug does not occur
  • Tested in IE6/7 in XP/Vista

I hope this is clear enough, it's my first bug submission. Thanks.

Change History

comment:1 Changed 6 years ago by arczi

  • Keywords Confirmed IE added

Definitely confirmed. It is important to use scroll bar, not mouse scroll.

comment:2 Changed 6 years ago by williamsn

  • Cc nicholas@… added

I can provide a few more details, if it helps.

First, this problem only occurs if you scroll beyond the cursor, and only if you scroll by clicking on the scroll bar to scroll. If you use the mouse scroll wheel or touch pad scrolling shortcuts, it doesn't happen.

Second, you don't just have to click on a submit button to encounter this problem. All you have to do is click within the HTML editor window, scroll beyond the cursor, then click on the body of the document somewhere. That will cause the window jump.

Finally, this behavior does not appear to happen if you click on text boxes or other text areas or other HTML editor instances within the same form. Only if you click on a submit button or the document body.

We can also confirm this bug was not present in versions before 2.6.3 and that it still exists.

comment:3 Changed 5 years ago by sandermens

  • Priority changed from Normal to High
  • Version changed from FCKeditor 2.6.3 to FCKeditor 2.6.4

I have the same problem. Very anoying because a client mentioned the problem and I cannot get it fixed.

I only get the bug in IE7 and lower. Not in IE8. And the problem is still remaining in the last version 2.6.4.

comment:4 Changed 5 years ago by alfonsoml

  • Priority changed from High to Normal
  • Version changed from FCKeditor 2.6.4 to FCKeditor 2.6.3

comment:5 Changed 5 years ago by arczi

#3867 has been marked as DUP

comment:6 Changed 5 years ago by savagekabbage

Seeing the same issue here. Focus is jumping in IE6-7 if you use the scroll bar. Anyone have a solution to this?

comment:7 Changed 5 years ago by aconex

  • Priority changed from Normal to High

We are also having this issue. We recently upgraded from 2.3.2 to 2.6.4 on your web application and this problem has only manifested itself since the upgrade went live.

The problem only occurs using the scroll bar, the mouse wheel works fine.

This is a major issue for us, is there a solution in the pipeline?

comment:8 Changed 5 years ago by jmd

+1 for getting this fixed, it has affected us as well.

comment:9 Changed 5 years ago by gmarshall

I just wanted to let anyone who's still following this know that the bug does not appear in the newest version, CKEditor 3.0. So I assume it will not be fixed in FCKeditor, since CKEditor replaces it (http://ckeditor.com). I am removing the pages referenced in the original bug ticket above, since I think this is pretty much resolved.

comment:10 Changed 5 years ago by jet

  • Keywords JUMP BUG CONFIRMED added; Confirmed removed
  • Summary changed from Window "jumps" and does not submit when submit button clicked (IE) to Jump bug still there in CKEditor 3.1
  • Version changed from FCKeditor 2.6.3 to 3.1
  • Milestone set to CKEditor 3.x

Hello,

I am new to this forum.

Installed CKEditor v 3.1 and I also have this jumping problem.

IE 8 : long text edited. I scroll down, click in the editor area. The editor jumps back at the top of the text. It is really a problem for my customers.

Customers were okay to use Firefox, but they found another bug in Firefox. When pasting from word part of the infos in the foot notes are lost. My customers have foot notes in almost in every article.

So I have them paste their document in IE, save, close IE, open FF, and edit the document in FF. I feel a bit ridiculous.

This issue is not at all resolved. Can you please give it a high priority.

Jet

comment:11 Changed 5 years ago by alfonsoml

  • Keywords Confirmed added; JUMP BUG CONFIRMED removed
  • Priority changed from High to Normal
  • Summary changed from Jump bug still there in CKEditor 3.1 to Window "jumps" and does not submit when submit button clicked (IE)
  • Version changed from 3.1 to FCKeditor 2.6
  • Milestone CKEditor 3.x deleted

comment:12 Changed 3 years ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to invalid

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy