Ticket #3010 (closed Task: fixed)

Opened 6 years ago

Last modified 5 years ago

Enhance testing framework regards 'selection range' testing

Reported by: garry.yao Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.1
Component: QA Version: 3.0 Beta 2
Keywords: Confirmed HasTest Cc:

Description (last modified by garry.yao) (diff)

  1. Document content along with selection testing regards various command execution result could be simplified as comparison based on our widely used selection description language, which make test case easy to write and understand by people, so a translation API could be provided to make the editor understand this language.
  • represent single selection
<p>
	This is some <strong>[sample text]</strong>.</p>
  • represent multiple selection
<table>
	<tbody>
		<tr>
			<td>
				Text1
			</td>
			<td>
				[Text2]
			</td>
		</tr>
		<tr>
			<td>
				[Text3]
			</td>
			<td>
				Text4
			</td>
		</tr>
	</tbody>
</table>
<br />

  • represent collapsed selection
    	This is some <strong>sample^ text</strong></p>
    
  1. Secondly, in order to avoid embed html string in JavaScript codes, it's more convenient to utilize a <textarea> to hold the actually expected/provided descriptive HTML codes( the reason for bypass <pre> is because IE's unable to preserve original format when retrieving content dynamically). So a cross-browser implementation could be established to get pre-formatted content with ease.

Attachments

test-selectionrange-api.html (1.2 KB) - added by garry.yao 6 years ago.
Proposed selection test sample.

Change History

Changed 6 years ago by garry.yao

Proposed selection test sample.

comment:1 Changed 6 years ago by garry.yao

  • Owner set to garry.yao
  • Keywords Confirmed added
  • Status changed from new to assigned

comment:2 Changed 6 years ago by fredck

  • Component changed from General to QA
  • Milestone CKEditor 3.0 deleted

comment:3 Changed 5 years ago by alfonsoml

  • Version changed from SVN (FCKeditor) to CKEditor 3.0 Beta 2

comment:4 Changed 5 years ago by garry.yao

  • Milestone set to CKEditor 3.1

This function should be provided as an CKEDITOR.test API.

comment:5 Changed 5 years ago by garry.yao

  • Keywords Review? added

comment:6 Changed 5 years ago by garry.yao

  • Keywords HasTest added; Review? removed
  • Description modified (diff)

Changes committed with #4144, leave the ticket open for collecting feebacks.

comment:7 Changed 5 years ago by garry.yao

Typo: #4144 -> [4144].

comment:8 Changed 5 years ago by garry.yao

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy