Opened 7 years ago

Closed 6 years ago

#3257 closed Bug (fixed)

List doesn't preserve block style

Reported by: garry.yao Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.3
Component: Core : Lists Version: SVN (CKEditor) - OLD
Keywords: Confirmed Review+ Cc:

Description

Reproducing Procedures

  1. Open the replace by class example page;
  2. Open 'Format' combo and select 'Heading 1' style;
  3. Click on 'Numbered List' to apply list format;
    • Actual Result:
      <ol>
      	<li>
      		This is some <strong>sample text</strong>. You are using <a href="http://www.fckeditor.net/">FCKeditor</a>.</li>
      </ol>
      
    • Expected Result:
      <ol>
      	<li>
      		<h1>
      				This is some <strong>sample text</strong>. You are using <a href="http://www.fckeditor.net/">FCKeditor</a>.</h1></li>
      </ol>
      

Attachments (2)

3275.patch (1.2 KB) - added by garry.yao 6 years ago.
3257_2.patch (1.0 KB) - added by garry.yao 6 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 7 years ago by fredck

  • Priority changed from High to Normal

comment:2 Changed 7 years ago by fredck

  • Milestone changed from CKEditor 3.0 to CKEditor 3.x

comment:3 Changed 6 years ago by garry.yao

  • Component changed from General to Core : Lists
  • Version set to SVN (CKEditor)

#5271 has been marked as duplicate of this bug.

comment:4 Changed 6 years ago by satya

  • Milestone changed from CKEditor 3.x to CKEditor 3.3

The duplicate defect #5271 had this as 3.3. Moving this milestone to 3.3 also. We need to understand the status of this issue.

Changed 6 years ago by garry.yao

comment:5 Changed 6 years ago by garry.yao

  • Keywords Confirmed Review? added
  • Owner set to garry.yao
  • Status changed from new to assigned

comment:6 Changed 6 years ago by fredck

  • Keywords Review- added; Review? removed

I'm not sure, but maybe a simpler logica can be found for this one:

if contentBlock is header
   remove contentBlock and append it to listItem
else
   append the contentBlock children to listItem and remove it

Am I wrong?

Changed 6 years ago by garry.yao

comment:7 follow-up: Changed 6 years ago by garry.yao

  • Keywords Review? added; Review- removed

You're neat, so how about inherit the block styles to list item also?

comment:8 in reply to: ↑ 7 Changed 6 years ago by fredck

  • Keywords Review+ added; Review? removed

Replying to garry.yao:

You're neat, so how about inherit the block styles to list item also?

Theoretically, we could have more benefits than issues with it, so let's see.

comment:9 Changed 6 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [5456].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy