Ticket #3291 (closed Bug: fixed)

Opened 6 years ago

Last modified 6 years ago

Ctrl-V does not work in Paste from Word dialog

Reported by: martinkou Owned by: martinkou
Priority: Normal Milestone: CKEditor 3.0
Component: UI : Dialogs Version: SVN (CKEditor) - OLD
Keywords: Oracle Confirmed Review+ Cc: Senthil

Description

To reproduce:

  1. Open replacebyclass.html in IE.
  2. Open the Paste from Word dialog.
  3. Copy some random text from MS Word.
  4. Paste into the Paste from Word dialog with Ctrl-V.
  5. Nothing happens.

Attachments

3291.patch (4.7 KB) - added by martinkou 6 years ago.

Change History

comment:1 Changed 6 years ago by arczi

  • Keywords Confirmed added

comment:2 follow-up: ↓ 5 Changed 6 years ago by martinkou

The problem occurs with JAWS only - Ctrl-V works without JAWS.

The problem with JAWS on is twofold, one is actually due to the dialog system's logic, the other is a JAWS bug that needs to be worked around.

  1. The editor actually tries to put the first focus into the first checkbox - because the focus logic of the iframe is not currently tied with the auto-focus system.
  2. JAWS's virtual cursor is confused when an editable iframe is created and put into display by JavaScript.

comment:3 Changed 6 years ago by martinkou

  • Keywords Review? added

I've tried for quite some time to make it work perfectly, but JAWS becomes serious broken in IE when there're layered focusable elements on the screen.

So after this patch is applied, the following will be fixed:

  1. The caret will be correctly and reliably put into the rich text area inside the Paste from Word dialog, after it's opened. Previously JAWS may put the focus back into background elements.
  2. Ctrl-V in IE can now work reliably when the editing area inside dialog is focused.
  3. The editing area inside the dialog is now announced in JAWS as "Rich text area, paste from word".
  4. Pressing tab and shift-tab from inside the editing area will now correctly cycle through the other dialog input elements without going to the background elements.

Changed 6 years ago by martinkou

comment:4 Changed 6 years ago by martinkou

One thing that I've tried for a while but couldn't manage to fix is typing inside the dialog's editing area in IE.

JAWS is very glitchy here - sometimes typing will work, but most of the time it doesn't. The only reliable way to make typing work inside the editing area in the dialog is to disable the virtual cursor via Insert-Z. Ctrl-V, however, works without Insert-Z.

comment:5 in reply to: ↑ 2 Changed 6 years ago by arczi

Replying to martinkou:

The problem occurs with JAWS only - Ctrl-V works without JAWS.

This bug occur also in my IE (7.0.6000) without JAWS. The cursor is visible, I can write something but CTRL+V doesn't work.

I replaced line 19 in dialog with:

+ 'setTimeout("window.focus();",0);'

and it starts working. With 3291.patch it also works.

comment:6 Changed 6 years ago by martinkou

Yes, part of the reason why it doesn't work in the trunk, even without JAWS, is that the autofocus system has put the focus to the checkbox just below the editing area. A simple setTimeout() hack gets around that, but the real fix is to make the focus system aware of non-standard input widgets like the editing area.

comment:7 Changed 6 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:8 Changed 6 years ago by martinkou

  • Status changed from new to closed
  • Resolution set to fixed

Fixed with [3433].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy