Opened 7 years ago

Closed 6 years ago

#3292 closed Bug (expired)

CKEDITOR.dom.range.getBoundaryNodes with collapsed range

Reported by: garry.yao Owned by:
Priority: Normal Milestone: CKEditor 3.1
Component: General Version:
Keywords: Cc:


Currently the 'getBoundaryNodes' function is returning incorrect elements when range is collapsed, based on the semantic of the function, it should return 'null' for boundary nodes instead.

Attachments (1)

range_boundaryNodes_collapsedRange.patch (1.8 KB) - added by garry.yao 7 years ago.
Unit Test Case

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by garry.yao

Unit Test Case

comment:1 Changed 7 years ago by garry.yao

A concrete example of failure caused by this bug would be when you asking 'CKEDITOR.dom.range.checkEndOfBlock' with the following, it will give a positive answer, which is wrong.


comment:2 Changed 7 years ago by fredck

  • Milestone changed from CKEditor 3.0 to CKEditor 3.1

It looks like we don't need getBoundaryNodes anymore. The code using it should now use the dom walker to achieve in boundaries processing.

We need to check it later.

comment:3 Changed 6 years ago by garry.yao

  • Resolution set to expired
  • Status changed from new to closed

There's still few usage of CKEDITOR.dom.range::checkEndOfBlock in the codebase but we're about to deprecate it, so this ticket expired.

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy