Opened 6 years ago

Closed 4 years ago

#3375 closed Bug (duplicate)

Unable to exit link

Reported by: garry.yao Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (CKEditor) - OLD
Keywords: Firefox Cc:

Description

If the very last element of the current paragraph is a link, it's not able to leave the 'a' element either by 'Arrow Right' or 'End' key.

Reproducing Procedures

  1. Open the replace by class example page;
  2. Make the following content along with selection:
    <p>text<a href="#">link^</a></p>
    
  3. Press End key, then begin to type some text;
    • Expected Result: The newly typed texts were not inside this link.
    • Actual Result: The newly typed texts were part of the link content.

Attachments (1)

3375.patch (1.9 KB) - added by garry.yao 6 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 6 years ago by garry.yao

  • Keywords Review? added
  • Owner set to garry.yao
  • Status changed from new to assigned

The proposed approach is about using a 'Inline Padding' node to establish a place holder for those boundary position, now it's able to both appending or exiting the link node.

Changed 6 years ago by garry.yao

comment:2 Changed 6 years ago by fredck

  • Keywords Review- added; Review? removed
  • We must not count on the invisibility of the "Zero Width No-Break Space" char to propose fixes that leave it in the document. Even if no space is taken by it, it makes the caret stop on it when moving with the arrows.
  • The way to create the Zero Width No-Break Space text node is wrong. The dom.text class can be used for that.
  • In any case, that's not a good solution for that. We must instead use the keystrokes to find out whether we need to move the selection out of the link or not. No padding nodes are needed. I would check how we do that on V2 first.

comment:3 Changed 6 years ago by fredck

  • Milestone changed from CKEditor 3.0 to CKEditor 3.1

comment:4 Changed 6 years ago by garry.yao

  • Milestone changed from CKEditor 3.1 to CKEditor 3.2
  • Owner garry.yao deleted
  • Status changed from assigned to new

comment:5 Changed 5 years ago by fredck

  • Milestone changed from CKEditor 3.2 to CKEditor 3.3

comment:6 Changed 5 years ago by garry.yao

  • Milestone changed from CKEditor 3.3 to CKEditor 3.x
  • Version set to SVN (CKEditor)

comment:7 Changed 5 years ago by fredck

  • Milestone CKEditor 3.x deleted

Milestone CKEditor 3.x deleted

comment:8 Changed 4 years ago by garry.yao

  • Keywords Firefox added

Looks like a Firefox only issue.

comment:9 Changed 4 years ago by wwalc

#5000 was marked as duplicate.

comment:10 Changed 4 years ago by wwalc

  • Resolution set to duplicate
  • Status changed from review_failed to closed

Duplicate of #5978 (closing this one because #5978 contains more information).

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy