Opened 7 years ago

Closed 6 years ago

#3389 closed Bug (fixed)

Keystroke for open/close submenu

Reported by: garry.yao Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.2
Component: Accessibility Version:
Keywords: IBM Confirmed Cc:

Description

There' no key assigned to help collapse submenu and go back to the first-level menu.

Attachments (5)

3389.patch (3.9 KB) - added by garry.yao 7 years ago.
3389_2.patch (4.5 KB) - added by garry.yao 7 years ago.
3389_3.patch (7.3 KB) - added by garry.yao 7 years ago.
3389_4.patch (5.7 KB) - added by garry.yao 7 years ago.
3389_5.patch (6.7 KB) - added by garry.yao 7 years ago.

Download all attachments as: .zip

Change History (23)

Changed 7 years ago by garry.yao

comment:1 Changed 7 years ago by garry.yao

  • Keywords Review? added
  • Owner set to garry.yao
  • Status changed from new to assigned

Arrow-Left OR ESC is assigned to do the job, I'll update user-guide after closing this ticket.

comment:2 Changed 7 years ago by garry.yao

The patch is containing the latest change of #3390 for easy reviewing.

comment:3 Changed 7 years ago by fredck

  • Milestone changed from CKEditor 3.0 to CKEditor 3.1

comment:4 Changed 7 years ago by fredck

  • Summary changed from Keystrike for open/close submenu to Keystroke for open/close submenu

comment:5 Changed 7 years ago by garry.yao

  • Keywords IBM added; Review? removed

#3951 has been marked as DUP.

comment:6 Changed 7 years ago by damo

Garry I think you meant #3952

comment:7 Changed 7 years ago by arczi

  • Component changed from General to Accessibility

Changed 7 years ago by garry.yao

comment:8 Changed 7 years ago by garry.yao

  • Keywords Review? added; Confirmed removed

Making necessary changes since it's quite a old patch.

comment:9 Changed 7 years ago by tobiasz.cudnik

  • Keywords Review- Confirmed added; Review? removed

There are problems on Safari4, reproduce like this:

  • Open context menu with submenu options (eg for table)
  • Move cursor to option with submenu
  • Press right arrow
  • Press left arrow

Expected: focus is back to previous option with submenu, option is highlighted and we can navigate up/down.

Actual: focus is missing, up/down navigation is impossible

Changed 7 years ago by garry.yao

comment:10 Changed 7 years ago by garry.yao

  • Keywords Review? added; Review- removed

Changed 7 years ago by garry.yao

comment:11 Changed 7 years ago by garry.yao

Provide a much more simplified patch.

comment:12 Changed 7 years ago by tobiasz.cudnik

  • Keywords Review- added; Review? removed

Patch works fine with one minor issue - in RTL mode, arrow which opens submenu should be reverted (from right to left).

comment:13 Changed 7 years ago by garry.yao

  • Milestone changed from CKEditor 3.1 to CKEditor 3.0.1

Changed 7 years ago by garry.yao

comment:14 Changed 7 years ago by garry.yao

  • Keywords Review? added; Review- removed

Incoming patch take care about the direction convention.

comment:15 Changed 7 years ago by fredck

  • Milestone changed from CKEditor 3.1 to CKEditor 3.2

comment:16 Changed 7 years ago by fredck

#4804 has been marked as DUP.

comment:17 Changed 7 years ago by garry.yao

  • Keywords Review? removed

Changes are checked in with [4977] on aria branch.

comment:18 Changed 6 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [5092] in 3.2.x branch.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy