Ticket #3530 (closed Bug: fixed)

Opened 5 years ago

Last modified 4 years ago

Hook FCKeditor_MediaWiki

Reported by: gnfroses Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Pending Cc:

Description

Getting this bug when trying to edit something on wiki. can someone give me a light?? thanks.

Detected bug in an extension! Hook FCKeditor_MediaWiki::onCustomEditor failed to return a value; should return true to continue hook processing or false to abort.

Backtrace:

#0 /var/www/html/mediawiki/includes/Wiki.php(497): wfRunHooks('CustomEditor', Array) #1 /var/www/html/mediawiki/includes/Wiki.php(63): MediaWiki->performAction(Object(OutputPage), Object(Article), Object(Title), Object(User), Object(WebRequest)) #2 /var/www/html/mediawiki/index.php(114): MediaWiki->initialize(Object(Title), Object(Article), Object(OutputPage), Object(User), Object(WebRequest)) #3 {main}

Change History

comment:1 Changed 5 years ago by arczi

  • Keywords Pending added
  • Component changed from General to Project : MediaWiki+FCKeditor

Could you provide the version of the mediawiki and FCKeditor?

comment:2 Changed 5 years ago by gnfroses

mediawiki: 1.14 FCK: last stable version

comment:3 Changed 5 years ago by Niels

I am getting this same error since upgrading my macports install, which includes my apache2, php5, and postgresql (upgrade included postgresql83 to postgresql84). Running both mediawiki and fckeditor both from svn trunk; just updated both (fckeditor 4166 and mediawiki 55683).

Detected bug in an extension! Hook FCKeditor_MediaWiki::onCustomEditor failed to return a value; should return true to continue hook processing or false to abort.

Backtrace:

#0 /opt/local/apache2/htdocs/w/includes/Wiki.php(515): wfRunHooks('CustomEditor', Array)
#1 /opt/local/apache2/htdocs/w/includes/Wiki.php(67): MediaWiki->performAction(Object(OutputPage), Object(Article), Object(Title), Object(User), Object(WebRequest))
#2 /opt/local/apache2/htdocs/w/index.php(117): MediaWiki->performRequestForTitle(Object(Title), Object(Article), Object(OutputPage), Object(User), Object(WebRequest))
#3 {main}

I am getting this error from php when php.ini error_reporting is set to E_ALL & ~E_DEPRECATED

Warning:  Parameter 1 to FCKeditor_MediaWiki::onCustomEditor() expected to be a reference, value given in /opt/local/apache2/htdocs/w/includes/Hooks.php

I am getting these errors from php when php.ini error_reporting is set to E_ALL | E_STRICT

Strict Standards: Declaration of FCKeditorParserWrapper::internalParse() should be compatible with that of Parser::internalParse() in /opt/local/apache2/htdocs/w/extensions/FCKeditor/mw12/FCKeditorParserWrapper.body.php on line 36

Strict Standards: Declaration of FCKeditorParser::makeImage() should be compatible with that of FCKeditorParserWrapper::makeImage() in /opt/local/apache2/htdocs/w/extensions/FCKeditor/FCKeditorParser.body.php on line 707

Strict Standards: Declaration of FCKeditorParser::parse() should be compatible with that of FCKeditorParserWrapper::parse() in /opt/local/apache2/htdocs/w/extensions/FCKeditor/FCKeditorParser.body.php on line 707

Strict Standards: Declaration of FCKeditorParser::formatHeadings() should be compatible with that of Parser::formatHeadings() in /opt/local/apache2/htdocs/w/extensions/FCKeditor/FCKeditorParser.body.php on line 707

Warning: Parameter 1 to FCKeditor_MediaWiki::onCustomEditor() expected to be a reference, value given in /opt/local/apache2/htdocs/w/includes/Hooks.php on line 133

any ideas?

comment:4 in reply to: ↑ description Changed 5 years ago by Niels

I ended up switching to the mediawiki fork of fckeditor, which seems to work just fine.

comment:5 Changed 4 years ago by solweig

  • Status changed from new to closed
  • Resolution set to fixed

The problem is the php version (>= 5.3.0), just modify in file : FCKeditor.body.php

public function onCustomEditor(&$article, &$user) {

global $wgRequest, $mediaWiki;

....

by

public function onCustomEditor($article, $user) {

global $wgRequest, $mediaWiki;

....

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy