Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#3611 closed Bug (duplicate)

Automatic option doesn't work for font and background color

Reported by: highjinx_53 Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (CKEditor) - OLD
Keywords: HasPatch Confirmed Cc:


The automatic option for these dropdowns never works. To reproduce type any text into one of the nightly samples, highlight the text and change its color to a specific color. Then click the Automatic option. The text will remain colored.

This is because of a bug in The problem is that checkElementRemovable, when called from removeInlineStyle, should match any element with the color or background-color style, regardless of value. Attached is a patch which fixes this.

Attachments (1)

3611.patch (2.0 KB) - added by highjinx_53 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by highjinx_53

comment:1 Changed 6 years ago by arczi

  • Keywords hasPatch Confirmed added; HasPatch removed
  • Milestone set to CKEditor 3.x

comment:2 Changed 6 years ago by arczi

  • Resolution set to duplicate
  • Status changed from new to closed

DUP of #3728

comment:3 Changed 6 years ago by fredck

  • Keywords HasPatch added; hasPatch removed
  • Milestone CKEditor 3.x deleted
Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy