Opened 7 years ago

Closed 7 years ago

#3677 closed Bug (fixed)

Image inside floating div cannot be linked, looses focus on IE7

Reported by: kontogou Owned by: martinkou
Priority: Normal Milestone: FCKeditor 2.6.5
Component: General Version: FCKeditor 2.6.4
Keywords: IE Confirmed Review+ Cc:

Description

Add an image inside a floating div:

<div style="float: right"><img src="..." /></div>

If you select the image and press the Add Link button, the link (<a>) is positioned at the beggining of the editor content as text and not at the image.

Alternatively, if you select the image and try to enter a link from the Link tab of Image Properties dialog, you get Javascript errors in IE7:

Line 82: 'undefined' is null or not an object

Line 789: Object doesn't support this property or method

It seems that line 256 of fck_image.js: (

oLink = oEditor.FCK.CreateLink( sLnkUrl )[0] ;

) does not return an object.

The cause is that the editor looses selection when CreateLink is called inside a floating image. If you edit an existing link with image, all is OK.

This bug is related to ticket #798 which is resolved in FCKEditor 2.6.4

Attachments (1)

3677.patch (2.3 KB) - added by martinkou 7 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 7 years ago by garry.yao

  • Keywords IE Confirmed added; float image link removed
  • Milestone set to FCKeditor 2.6.5

Confirmed on all IE versions, connected with V3: #3678.

comment:2 Changed 7 years ago by martinkou

  • Owner set to martinkou
  • Status changed from new to assigned

Changed 7 years ago by martinkou

comment:3 Changed 7 years ago by martinkou

  • Keywords Review? added

comment:4 Changed 7 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:5 Changed 7 years ago by martinkou

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [3974].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy