Opened 7 years ago

Closed 6 years ago

#3678 closed Bug (fixed)

[IE] Edit image link result incorrect inside floated div

Reported by: garry.yao Owned by:
Priority: Normal Milestone: CKEditor 3.2
Component: UI : Context Menu Version: SVN (CKEditor) - OLD
Keywords: IE Confirmed Cc:

Description (last modified by garry.yao)

  1. Open the 'replace by class' sample page in IE, load the editor with following content:
    	<div style="float:right">
    		<a href="http://a.com"><img alt="" src="http://dev.fckeditor.net/chrome/site/logos.gif"/></a>
    	</div>
    
  2. Select the image by clicking on it or from the elements path bar.
  3. Right click to open context menu and select 'Unlink';
  • Actual Result: The link is not removed from the image.

Change History (9)

comment:1 Changed 7 years ago by garry.yao

Actually all floated elements are treated as control type in design mode with IE.

comment:2 Changed 7 years ago by garry.yao

  • Description modified (diff)

The bug is proven by TC ( TC passed in all browsers ) that not related to #3677, correct the description.

comment:3 Changed 7 years ago by garry.yao

  • Resolution set to duplicate
  • Status changed from new to closed

Confirmed to be yet another DUP of #4041.

comment:4 Changed 7 years ago by garry.yao

  • Milestone changed from CKEditor 3.1 to CKEditor 3.2
  • Resolution duplicate deleted
  • Status changed from closed to reopened

It turns out that #4041 will not handle this bug, reopen it.
Manual TCs added at : http://ckeditor.t/tt/3678/1.html

comment:5 Changed 7 years ago by fredck

#4749 may be related to this.

comment:6 Changed 7 years ago by garry.yao

Supposed to be fixed by #4647.

comment:7 Changed 6 years ago by garry.yao

  • Component changed from General to UI : Context Menu
  • Resolution set to fixed
  • Status changed from reopened to closed
  • Version set to SVN (CKEditor)

Fixed by #4647.

comment:8 Changed 6 years ago by fredck

  • Resolution fixed deleted
  • Status changed from closed to reopened

We still need a changelog entry for this one, even if it has been fixed in another ticket.

comment:9 Changed 6 years ago by fredck

  • Resolution set to fixed
  • Status changed from reopened to closed

Changelog added with [5025].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy