Ticket #3805 (closed Bug: fixed)

Opened 5 years ago

Last modified 5 years ago

The SCAYT plugin is disabled in IE

Reported by: fredck Owned by: tobiasz.cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: UI : Spell Checker Version: SVN (CKEditor) - OLD
Keywords: Confirmed IE Review+ Cc: SpellChecker.net

Description

Because of #3802, we've been forced to disable the SCAYT plugin in IE. We should instead fix an re-enable it.

Attachments

3805.patch (2.9 KB) - added by tobiasz.cudnik 5 years ago.

Change History

comment:1 Changed 5 years ago by SpellChecker.net

Updated comments from 3726, taking into account comments #3802: we are able to reproduce the problem in specific conditions.

We have re-tested the nightly build at demo nightly.ckeditor.com, nightly build deployed to our testing environment, nightly build from the file system. We got following results:

  1. on the file system configuration all of IE (6,7,8) hangs when trying to enable SCAYT
  1. on the nightly.ckeditor.com we can reproduce the problem in specific conditions.
  1. on the own testing environment we can not reproduce the problem in specific conditions.

details on "specific conditions": we are using virtual machine with 256MB of RAM and single CPU and with windows XP SP2, without any updates installed to test IE6 environment.

When we just start IE process, open sample page and enable SCAYT - browser may work for some period of time fine without consuming 100% of CPU. That's why we were not able to reproduce the problem at

When we start IE, open sample page, and reloading this page several times (3-5) - we can reproduce the problem with 100% probability.

One thing we have noted during this testing: if page with editor is reloaded in IE6 then IE6 consume about 3MB of additional memory for each CKeditor instance on the page: if we have sample page with one instance of editor on the page each reload adds about 3MB of memory to IEXPLORE.EXE process, if we have two instances then each reload adds about 6MB of memory to IEXPLORE.EXE process. We have tested it in the last SVN version with SCAYT plug-in disabled in all IEs.

The problem can not be reproduced in IE7 and 8.

Does it make a sense to change the patch so it does disable SCAYT plug-in not in all IEs environment, but only in IE6 for now?

Does it make a sense to disable SCAYT in file system or any other non hosted environments , i.e. only when protocol is not http or https?

We plan to perform additional testing for IE6 and will update this ticket.

comment:2 Changed 5 years ago by SpellChecker.net

We finally reproduced conditions when SCAYT freezes in IE. We need to fix this problem in the SCAYT core. SCAYT freezes right after the point symbol is typed (as described in Martin's screencast).

The problem is actual for all IE.

We'll update this ticket when the problem will be resolved.

comment:3 Changed 5 years ago by SpellChecker.net

We have fixed problem in the SCAYT core.

comment:4 Changed 5 years ago by tobiasz.cudnik

  • Owner set to tobiasz.cudnik
  • Status changed from new to assigned

Changed 5 years ago by tobiasz.cudnik

comment:5 Changed 5 years ago by tobiasz.cudnik

  • Keywords Review? added

I've made a test in all IE versions and couldn't reproduce this issue anymore.

Attached patch re-enables SCAYT in all IEs.

comment:6 Changed 5 years ago by garry.yao

  • Keywords Review+ added; Review? removed

comment:7 Changed 5 years ago by tobiasz.cudnik

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed with [3791].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy