Ticket #3822 (closed Bug: expired)

Opened 5 years ago

Last modified 5 years ago

CKeditor 3.x - IE7 and IE8 displaying text box too low

Reported by: cpeters Owned by:
Priority: Normal Milestone:
Component: UI : Floating Panel Version: 3.0 Beta 2
Keywords: Pending Cc:

Description

I'm using the replacebyclass method which seems to render the editor correctly in every browser except IE (have tried Safari, FF and Chrome). Within IE, the actual edit box (where you can type) is much lower in the window than it should be. In non-IE browsers you can start typing directly after the toolbar, which makes sense.

Here's an example:

Attachments

hit example.jpg (73.1 KB) - added by cpeters 5 years ago.
screenshot in IE
FCKeditor Example.jpg (264.4 KB) - added by cpeters 5 years ago.
FCK Editor Example (works)
FCKEditor Example.txt (108.3 KB) - added by cpeters 5 years ago.
FCK Editor Source Code (works)
CKeditor Example.jpg (241.3 KB) - added by cpeters 5 years ago.
CKEditor Example (doesn't work)
CKEditor Example.txt (205.7 KB) - added by cpeters 5 years ago.
CKEditor Source Code (doesn't work)
detail.html (178.6 KB) - added by cpeters 5 years ago.
IE html Sample (watered down)
307570.htm (2.4 KB) - added by cpeters 5 years ago.
Chrome Version (complete web save)
307570 files.jpg (47.8 KB) - added by cpeters 5 years ago.
Other files from Chrome Save

Change History

Changed 5 years ago by cpeters

screenshot in IE

comment:1 Changed 5 years ago by fredck

  • Keywords Pending added

That one sounds really strange, because it actually works in our sample pages.

Do you think you would be able to provide or even show us a page containing this problem? It would be hard to understand this issue without it.

Thanks in advance.

Changed 5 years ago by cpeters

FCK Editor Example (works)

Changed 5 years ago by cpeters

FCK Editor Source Code (works)

Changed 5 years ago by cpeters

CKEditor Example (doesn't work)

Changed 5 years ago by cpeters

CKEditor Source Code (doesn't work)

comment:2 follow-up: ↓ 4 Changed 5 years ago by cpeters

I've continuted to play with this without luck. I can't really provide a working sample for you as this is being implemented within a PeopleSoft application.

For some additional background, I am applying this in a DEV environment whereas our production environment runs (correctly, without issue) the FCKEditor. I'm attempting to upgrade to CKEditor b/c I can't get FCKedtior to work in IE8. In hopes that the comparison approach will work, I'm attaching a .jpg screenshot of the same page from both environments. I'm also including the source code behind those pages.

Something I find interesting is that the CKEditor version places a wrap around the actual text area:

<!-- overlap: Field Z_ISSUE_WRK.COMMENTS_2000_WRK type=longedit refpt=(8,820) size=936Wx184H left --><textarea name='Z_ISSUE_WRK_COMMENTS_2000_WRK' id='Z_ISSUE_WRK_COMMENTS_2000_WRK' tabindex='133' class='PSLONGEDITBOX' style="width:936px; height:147px; " cols='153' rows='11' wrap='virtual'></textarea><a name='Z_ISSUE_WRK_COMMENTS_2000_WRK$spellcheck' id='Z_ISSUE_WRK_COMMENTS_2000_WRK$spellcheck' tabindex='134' href="javascript:submitAction_win2(document.win2,'Z_ISSUE_WRK_COMMENTS_2000_WRK$spellcheck');"><img src="/cs/HITDEV/cache/PT_SPELLCHECK_1.gif" alt='Spell Check Add a Comment (Alt+5)' title='Spell Check Add a Comment (Alt+5)' name='Z_ISSUE_WRK_COMMENTS_2000_WRK$spellcheck$img' border='0' align='top' /></a> </td> </tr> <tr> <td height='39' colspan='2'></td> <td valign='top' align='left'> <!-- overlap: Field type=frame refpt=(904,967) size=2Wx12H left -->

Hope this helps. I'm at a loss at this point. Thanks again for looking into this.

comment:3 Changed 5 years ago by fredck

I'm wondering if it's a problem with CSSs on the page that are breaking the editor skin.

I can see that you're using the default skin for Beta 2, which is now called "v2". Do you have changed the skin?

I've tried to reproduce the problem here based on the HTML of your page, but it works for me with the current trunk. I think there are still other things missing that could help us.

Do you think you can ask IE to save the page, using the "Webpage, complete" option?

We'll not be able to fix it if we can't reproduce it here.

comment:4 in reply to: ↑ 2 Changed 5 years ago by fredck

Replying to cpeters:

I can't really provide a working sample for you as this is being implemented within a PeopleSoft application.

We don't need access to your application. All we need is an HTML page that shows the same problem (probably derived from your application page). We need a reduced test case.

Changed 5 years ago by cpeters

IE html Sample (watered down)

Changed 5 years ago by cpeters

Chrome Version (complete web save)

Changed 5 years ago by cpeters

Other files from Chrome Save

comment:5 Changed 5 years ago by cpeters

IE wouldn't let me save for some reason. Chrome allowed it so I've attached that version (which does work in Chrome). Possibly you could open this in IE on your end. I didn't attach all of the files from the actual full web save, just the htm file but provided a screenshot of the remaninig files. I'm happy to attach any of them if needed.

I also tried to waterdown a version of the IE source code and I've attached that as well.

comment:6 Changed 5 years ago by fredck

  • Milestone CKEditor 3.x deleted

I'm having no lucky with you files. You should be able to reproduce the problem there with these files also, first of all. Just sending them us as is don't help much.

I mean, you should create a test case locally, that confirms the issue. At that point, zip everything needed to reproduce it and append the necessary information to this ticket.

comment:7 Changed 5 years ago by cpeters

Possibly I should ask this another way. Is there anything I can do to get FCKEditor to work in IE8?

comment:8 Changed 5 years ago by fredck

We're working on IE8 issues for FCKeditor 2.6.5. This has nothing to do with this ticket though.

comment:9 Changed 5 years ago by cpeters

Agreed it has nothing to do with this ticket other than that's the only reason I'm trying to get CKEdtior 3x to work for me. Otherwise, I'd just stick with FCK 2.6.5. I was asking in hopes of abandoning the work effort to get CK3x to work.

Feel free to close this ticket.

comment:10 Changed 5 years ago by fredck

I meant, having FCKeditor working for you will not help us having CKEditor fixed for this issue. Our intention (in this ticket) is having CKEditor fixed. If your intention is just having your system working, then it would be better starting a discussion at our forums asking for help, instead of opening a ticket.

This is not a direct criticism for you. Don't get me wrong. I just want to clarify what the ticket system is intended for. It's not a support channel.

If you're interested on having this ticket (which you have opened) fixed, we really need your help.

comment:11 Changed 5 years ago by alfonsoml

The SVN of FCKeditor works correctly with IE8 if you apply also #2156 (that affects any IE), #3181 and you aren't setting document.domain in your page.

comment:12 Changed 5 years ago by alfonsoml

  • Status changed from new to closed
  • Resolution set to expired

Without a working test page nothing can be done. And probably the bug will remain there in the event that you want to upgrade to CKEditor in the future.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy