Opened 7 years ago

Closed 7 years ago

#3835 closed Bug (fixed)

element path not refreshed on 'newpage'

Reported by: garry.yao Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: IE Safari Confirmed Review+ Cc:

Description

Reproducing Procedures

  1. Open the replace by class example page;
  2. Click on 'New Page' button to clear all content;
    • Exptected Result: Element path show nothing;
    • Actual Result: Element path is still showing the old selection path.

Attachments (2)

3835.patch (1.3 KB) - added by garry.yao 7 years ago.
3835_2.patch (1.7 KB) - added by garry.yao 7 years ago.

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by garry.yao

comment:1 Changed 7 years ago by garry.yao

  • Keywords Review? added
  • Status changed from new to assigned

comment:2 Changed 7 years ago by fredck

  • Keywords Review- added; Review? removed
  • I'm not able to confirm this bug in IE, only with Safari.
  • The patch is broken, and actually we can see a "?" being added at the start of _source/core/dom/window.js.
  • It's not clear how the changes on _source/plugins/wysiwygarea/plugin.js could help on this fix.
  • There is no changelog.

comment:3 Changed 7 years ago by fredck

  • Keywords Safari added; Webkit removed

Btw, the correct keyword is "Safari", not "WebKit".

Changed 7 years ago by garry.yao

comment:4 Changed 7 years ago by garry.yao

  • Keywords Review? added; Review- removed

Replying to fredck:

  • I'm not able to confirm this bug in IE, only with Safari.

Sorry, only IE8 is affected.

  • It's not clear how the changes on _source/plugins/wysiwygarea/plugin.js could help on this fix.

Yes, explaination should be putted here: any error that happened inside 'selectionChange' event handler will break other listeners and error is been swallowed by a try/catch in selection plugin. So here elementpath refreshing as a handler is broken by error generated by wysiwyg plugin.

comment:5 Changed 7 years ago by fredck

  • Keywords Review+ added; Review? removed

Well... I'm still not able to reproduce it with IE, not even IE8. That fix doesn't hurt, and Safari got fixed.

comment:6 Changed 7 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [3775].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy