Opened 7 years ago

Closed 7 years ago

#3973 closed Bug (fixed)

Bulleted List Bug IE8

Reported by: wackyphill Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.0
Component: Core : Lists Version:
Keywords: IE Confirmed Review+ Cc:


In the nightly build you can cause this error by doing the following:

Type some text on a new line. Then bold and underline the text.

Press ENTER to move to the next line. Then press the bulleted List Item on the toolbar to create a bulleted list.

This causes a javascript error.

Attachments (1)

3973.patch (1.9 KB) - added by garry.yao 7 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 7 years ago by garry.yao

  • Component changed from General to Core : Lists
  • Keywords IE Confirmed added
  • Owner set to garry.yao
  • Priority changed from High to Normal
  • Status changed from new to assigned

Changed 7 years ago by garry.yao

comment:2 Changed 7 years ago by garry.yao

  • Keywords Review? added

Regression from #3887.
The error is triggered by the following steps:

  1. When apply inline style, a empty text node is created after the <body> due to the following dirty codes:
    		// Probably the document end is reached, we need a marker node.
    		if ( !lastNode )
    				lastNode = document.createText( '' );
    				lastNode.insertAfter( range.endContainer );
  2. When create list, the special treatment logic added in [3850] is incorrectly triggered, where it try to check if the empty text node is at the boundary of a <html> element, result in an error.

I'm providing a temporary fix here while a decent solution should be found later.

comment:3 Changed 7 years ago by fredck

  • Keywords Review+ added; Review? removed

May be temporary, but it's logic and efficient.

comment:4 Changed 7 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [3926]. Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy