Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#4049 closed Bug (fixed)

Kama skin too wide with config.width

Reported by: tobiasz.cudnik Owned by: tobiasz.cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: Kama Review+ Confirmed reopen Cc:

Description

Kama skin is too wide when config.width is used. Difference is 12px, which cames from padding (2x 5px) and borders (2x 1px).

Kama skin should include those measures when setting it's width to desired size.

Attachments (2)

4049.patch (1.1 KB) - added by tobiasz.cudnik 7 years ago.
4049_2.patch (1.1 KB) - added by tobiasz.cudnik 7 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 7 years ago by tobiasz.cudnik

  • Owner set to tobiasz.cudnik
  • Status changed from new to assigned

Changed 7 years ago by tobiasz.cudnik

comment:2 Changed 7 years ago by tobiasz.cudnik

  • Keywords Review? added

comment:3 Changed 7 years ago by fredck

  • Keywords Review- added; Review? removed

The width setting may be a non numberic value, like "80%" or "80em". This fix should apply to the numeric values only.

Changed 7 years ago by tobiasz.cudnik

comment:4 Changed 7 years ago by tobiasz.cudnik

  • Keywords Review? added; Review- removed

Right, fixed in second patch.

comment:5 Changed 7 years ago by tobiasz.cudnik

  • Keywords Confirmed added

comment:6 Changed 7 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:7 Changed 7 years ago by tobiasz.cudnik

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [3957].

comment:8 Changed 6 years ago by boutell

  • Keywords reopen added

I am experiencing this bug in CKEditor 3.5.3, downloaded April 30th, 2011. If I use the kama skin and a width in pixels, it's 12 pixels too wide. If I use the v2 skin it's fine.

ckeditor is great stuff, keep it up

comment:9 Changed 6 years ago by boutell

In my tests the width is set to 100% (note percentage). My suspicion is that the bug is only fixed for widths in pixels.

comment:10 follow-up: Changed 5 years ago by mark100net

I don't understand how this is classified as fixed.

I made a bare bones page in version 3.6.2. I modified only two options as follows:

CKEDITOR.config.height = 633; CKEDITOR.config.width = 1024;

And the editing area is 1002 pixels wide and 633 pixels high.

I have to monkey raise the width setting to 1046 to get the width that I want.

comment:11 in reply to: ↑ 10 Changed 5 years ago by fredck

Replying to mark100net:

Note that config.width sets the outer width of the editor, not the editing area width.

Considering that, it is working well for me on FF and IE9.

comment:12 follow-up: Changed 5 years ago by mark100net

Why doesn't the documentation say this? Further, why doesn't the height work the same way? The height sets the editing area height, not the "outer height" of the editor. This should be consistent.

The bottom line is there should be a setting for this as it is important to be able to provide a tool where the author knows that the editor workspace is the same as in the ultimate environment where authored content will be used. We shouldn't have to monkey hack the width based on padding or other factors that may change.

comment:13 in reply to: ↑ 12 Changed 5 years ago by fredck

Replying to mark100net:

Why doesn't the documentation say this?

In fact, there is always space for enhancement, based on suggestions. I have enlarged the docs with [7378].

Further, why doesn't the height work the same way?

That's in fact what we always had with FCKeditor 2. But due to limitations of newer HTML standards, we were not able to have that same behavior with CKEditor 3 (we tried it hard, really).

The height sets the editing area height, not the "outer height" of the editor. This should be consistent.

The ability to set the outer width of the editor is very important (more than the height), because of page layout issues. People want to control the editor UI width with more precision. Additionally, it is mandatory to make it work with percent lengths (specially 100%). This would not work if we would apply the sizes in the inner editing area.

The bottom line is there should be a setting for this as it is important to be able to provide a tool where the author knows that the editor workspace is the same as in the ultimate environment where authored content will be used. We shouldn't have to monkey hack the width based on padding or other factors that may change.

That's an interesting point. I've opened #8793 for it.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy