Opened 6 years ago

Closed 3 years ago

#4079 closed Bug (expired)

[FF] Create list error no multiple items

Reported by: garry.yao Owned by: garry.yao
Priority: Normal Milestone:
Component: Core : Lists Version:
Keywords: Firefox Cc:

Description (last modified by garry.yao)

Reproducing Procedures

  1. Open the 'replace by class' sample page in Firefox;
  2. Load the document with the following content and selection with CTRL-A:
    [<p>line1</p>
    <p>line2</p>]
    
  3. Click on 'Insert Bulleted List' button;
    • Actual Result: Javascript error thrown.

Attachments (1)

4079.patch (2.4 KB) - added by garry.yao 6 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 6 years ago by garry.yao

  • Description modified (diff)
  • Keywords Firefox added; FF removed

Refine the description.

comment:2 follow-up: Changed 6 years ago by garry.yao

  • Keywords Confirmed added
  • Owner set to garry.yao
  • Status changed from new to assigned

Regression of [3930] where the function parameter refactoring is not complete.

Changed 6 years ago by garry.yao

comment:3 Changed 6 years ago by garry.yao

  • Keywords Review? added

Note that the incorrect result of the list is out the scope of this ticket.

comment:4 in reply to: ↑ 2 Changed 6 years ago by fredck

Replying to garry.yao:

Regression of [3930] where the function parameter refactoring is not complete.

Regression means it was working before [3930]... so there is no regression here.

comment:5 Changed 6 years ago by garry.yao

Reproducing Procedures

  1. Open the 'replace by class' sample page in Firefox;
  2. Clear all content with 'Ctrl-A' and then 'Del';
  3. Type "line1" + ENTER;
  4. Type "line2";
  5. Select all with 'Ctrl-A' and click on 'Insert/Remove Bulleted List' button;
    • Actual Result: Javascript error thrown.

comment:6 Changed 6 years ago by garry.yao

Above is a more precise way to catch it on Firefox3.0.12.

comment:7 Changed 6 years ago by fredck

  • Keywords WorksForMe added; Confirmed Review? removed
  • Milestone changed from CKEditor 3.0 to CKEditor 3.x
  • Priority changed from High to Normal

Me and Tobiasz are not able to reproduce this issue. Let's wait for others to confirm it before proceeding on changes here.

comment:8 Changed 5 years ago by fredck

  • Milestone CKEditor 3.x deleted

Milestone CKEditor 3.x deleted

comment:9 Changed 3 years ago by j.swiderski

  • Resolution set to expired
  • Status changed from pending to closed
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy