Opened 6 years ago

Closed 6 years ago

#4230 closed Bug (fixed)

HC detection causes js error

Reported by: fredck Owned by: tobiasz.cudnik
Priority: Normal Milestone: CKEditor 3.1
Component: General Version: SVN (CKEditor) - OLD
Keywords: Oracle Review+ Cc: Senthil


It has been reported that a JavaScript error is being thrown when including the ckeditor.js file into a page, but not using it. I mean, not creating any editor instance.

I'm not able to reproduce this issue in any way, which makes it hard to fix, but with help of the reporter I was able to identify the exact line that causes the error. It's the hcDetect.getComputedStyle( 'background-image' ) call in the _bootstrap.js code (currently line 25). It looks like it's not possible to retrieve the computed style at some time in the page execution flow and in a specific (unknown) case.

This is supposed to be a FF only issue.

As said, it's hard to fix this issue as we can't reproduce it. But, we could at least try changing the code or the detection system somehow. I'm CCing the reporter to this ticket so he can check if the patches work.

Attachments (1)

4230.patch (1.3 KB) - added by tobiasz.cudnik 6 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 6 years ago by tobiasz.cudnik

  • Owner set to tobiasz.cudnik
  • Status changed from new to assigned

comment:2 Changed 6 years ago by tobiasz.cudnik

  • Keywords Review? Pending added

This patch uses formal way of dealing with such errors, using exception handling.

I would like to ask Reporter for trying to reproduce the issue using new patch.

Changed 6 years ago by tobiasz.cudnik

comment:3 Changed 6 years ago by tobiasz.cudnik

This could also be related with #3905 and HC detection problem in FF 3.5.

comment:4 Changed 6 years ago by garry.yao

  • Keywords Review+ added; Review? Pending removed

Let's have this committed thanks to the change's not having big influence.

comment:5 Changed 6 years ago by tobiasz.cudnik

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [4175].

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy