Opened 7 years ago

Closed 7 years ago

#4514 closed Bug (fixed)

Editor edit area disables on back button

Reported by: bohnman Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.1
Component: General Version: 3.0
Keywords: Firefox Confirmed Review+ Cc:

Description

Environment - Firefox 3.5.3 on Mac OSX Leopard

This is reproducible in the samples, specifically replacebyclass.html

  • open up the sample html in FireFox
  • now go to another site like google
  • then, click back button so your back on the sample
  • you are now unable to click in the edit area until you toggle view source

Attachments (2)

4514.patch (908 bytes) - added by garry.yao 7 years ago.
4514_2.patch (1004 bytes) - added by garry.yao 7 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by garry.yao

  • Keywords Firefox added
  • Resolution set to wontfix
  • Status changed from new to closed

Known limitation of contentEditable in Firefox.

comment:2 Changed 7 years ago by garry.yao

  • Keywords Confirmed added
  • Milestone set to CKEditor 3.1
  • Resolution wontfix deleted
  • Status changed from closed to reopened

After some investigation, the FF bug behind this was reported here and it was lucky to find out a solution for both this bug and #3907.

comment:3 Changed 7 years ago by garry.yao

  • Keywords Review? added

Changed 7 years ago by garry.yao

comment:4 Changed 7 years ago by fredck

  • Owner set to garry.yao
  • Status changed from reopened to new

comment:5 Changed 7 years ago by fredck

  • Keywords Review- added; Review? removed

The patch is ok. I would just investigate other ways to apply onpageshow:

  1. In the proposed way, onpageshow could be in conflict with other code using it in the page. We must check if it's possible to set it as a normal event.
  1. We could try adding the onpageshow attribute in the content area instead. We may also try setting it directly to the <body> tag when creating the string we load in the editing area.

If none of the above are good for it, the provided patch would be ok.

Changed 7 years ago by garry.yao

comment:6 Changed 7 years ago by garry.yao

  • Keywords Review? added; Review- removed
  • Status changed from new to assigned

It's much more safe to preserve the original attribute now.

We could try adding the onpageshow attribute in the content area instead.

It's not working since the whole editing frame is cached too.

comment:7 Changed 7 years ago by fredck

  • Keywords Review+ added; Review? removed
  • You have reported a Mozilla bug for this issue, but it's not clear it's related to the same thing. Please be sure we have a bug for it there, making a reference to it here.
  • Be sure to close #3907 when closing this one.

comment:8 Changed 7 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

A more accurate bug report is delivered to Mozilla.
https://bugzilla.mozilla.org/show_bug.cgi?id=529321 Fixed with [4492].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy