Ticket #4605 (closed Bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

Ajax: Rich combo does not expand for every second or following editor

Reported by: niek Owned by:
Priority: High Milestone:
Component: General Version: 3.0.1
Keywords: Cc:

Description

When dynamicly creating a CKEditor instance, removing it and again creating an instance, the rich combo boxes (fomat, style, ...) no longer work. Not in IE, not in Firefox.

I thought it was my faulty implementation, but it seems the Ajax example in the _samples dir has the same problem.

Steps to reproduce:

  1. Open the ckeditor/_samples/ajax.html
  2. Click "Create Editor"
  3. Click on any rich combo box. It will open.
  4. Click "Remove Editor"
  5. Click "Create Editor"
  6. Click on any rich combo box. It no longer opens.

Firefox gives me the following error:

Error: this.$ is undefined Source File: ckeditor/ckeditor.js Line: 11

As a work-around I tried deleting the editor all together, which seems to work as long as I do NOT call destroy() on the editor:

CKEDITOR.instancesname?.destroy(); delete CKEDITOR.instancesname?;

This however causes other problems, which destroy() handles (e.g. events), so this has not worked for me.

Change History

comment:1 Changed 4 years ago by niek

New information:

When disabling the "this.theme.destroy(this);" call in the editor's destroy() method, this problem no longer occurs, so I'm guessing the default's theme destroy() method causes the problem...

comment:2 Changed 4 years ago by matti

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #4552 ( Float panel menu will not respond after the editor instance is re-created.)

Richcombo uses floatpanel

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy