Ticket #4717 (closed Bug: fixed)

Opened 4 years ago

Last modified 4 years ago

Remove Link and Outdent buttons should be disabled before editor gets focus

Reported by: JoeK Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Toolbar Version: SVN (CKEditor) - OLD
Keywords: IBM Confirmed Review+ Cc: dchojna@…

Description

When an editor instance gets created the Remove Link and Outdent buttons are enabled. When the editor first gets focus these buttons are disabled if they do not apply to the current text. The buttons should be initially disabled by default, and then, when the editor gets focus, only enabled if they apply to the current text.

Attachments

4717.patch (1.4 KB) - added by garry.yao 4 years ago.

Change History

comment:1 Changed 4 years ago by fredck

  • Milestone CKEditor 3.1 deleted

comment:2 Changed 4 years ago by damo

  • Milestone set to CKEditor 3.x

What is that status of this issue?

comment:3 Changed 4 years ago by fredck

  • Milestone changed from CKEditor 3.x to CKEditor 3.3

#4989 has been marked as DUP.

comment:4 Changed 4 years ago by garry.yao

  • Keywords Confirmed added
  • Owner set to garry.yao
  • Status changed from new to assigned
  • Component changed from General to UI : Toolbar
  • Version changed from 3.0.1 to SVN (CKEditor)

Changed 4 years ago by garry.yao

comment:5 Changed 4 years ago by garry.yao

  • Keywords Review? added

comment:6 Changed 4 years ago by alfonsoml

  • Keywords Review+ added; Review? removed

We will need some doc explaining the list of properties that can be used on the command objects because people won't know how to get this same feature in their plugins unless they happen to focus on that magic line

comment:7 Changed 4 years ago by garry.yao

  • Status changed from assigned to closed
  • Resolution set to fixed

Missing docs added.

Fixed with [5244].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy