Ticket #4726 (closed Bug: expired)

Opened 4 years ago

Last modified 4 years ago

having a submit button with name="submit" in the same form causes error IE7

Reported by: tyler45 Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0.1
Keywords: WorksForMe Cc:

Description

if you have a submit button with the name="submit" in the same form that you use the editor in, it throws a javascript error in IE7

line 22 ckeditor.js "object doesn't support this property or method.

i tracked it down to this bit of code in line 22

if(!z.$.submit.nodeName) {
	z.$.submit=e.override(z.$.submit,function(B) {
		return function() {
			x.updateElement();
			if(B.apply) {
				B.apply(this,arguments);
			} else {
				B();
			}
		};
	});
}

Windows Vista SP2 IE7

this does not happen in FF 3.5.5

(i was unable to test in nightly build, because unfort i don't know svn)

Change History

comment:1 Changed 4 years ago by garry.yao

  • Keywords WorksForMe added
  • Milestone CKEditor 3.x deleted

Unable to confirm on both trunk and nightly build.

comment:2 Changed 4 years ago by fredck

I've tested the trunk and the releases 3.0 and 3.0.1 and was not able to reproduce it. Can you please attach a sample page that shows the problem to you?

comment:3 Changed 4 years ago by alfonsoml

  • Status changed from new to closed
  • Resolution set to expired
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy