Opened 6 years ago

Closed 6 years ago

#4738 closed Bug (fixed)

Inserting table inside bold/italic/underline generates error on ENTER_BR mode

Reported by: pomu0325 Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.1
Component: General Version: 3.0.1
Keywords: Confirmed Review+ Cc: pomu@…

Description

It happens on IE and FF. Chrome seems to work fine. It seems to happen when the breadcrumb points 'body strong', and NOT happen when 'body p strong'.

steps to reproduce

  • Edit config.js to enable ENTER_BR mode.
    config.enterMode = CKEDITOR.ENTER_BR;
    
  • Open any sample page.
  • Goto source mode, and remove all texts.
  • Back to WYSIWYG mode, type some text.
  • Click B/I/U icon from toolbar.
  • Click Table icon from toolbar.
  • Press OK.
  • Then, javascript error occurs at elements.js(l.201), and typed text will cleared.
    • Error says: 'this.$ is null or not an object' (translated)

Attachments (1)

4738.patch (2.9 KB) - added by garry.yao 6 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by pomu0325

It does not occur on 3.0.0.

comment:2 Changed 6 years ago by pomu0325

It happens since [4344](fix for #3664) on trunk.

comment:3 Changed 6 years ago by fredck

  • Milestone set to CKEditor 3.1

Regression.

Changed 6 years ago by garry.yao

comment:4 Changed 6 years ago by garry.yao

  • Keywords Confirmed Review? added
  • Owner set to garry.yao
  • Status changed from new to assigned

comment:5 Changed 6 years ago by fredck

  • Keywords Review+ added; Review? removed

Please put a space after the "if" when committing.

comment:6 Changed 6 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [4663] and [4664].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy