Ticket #4960 (closed Bug: invalid)

Opened 5 years ago

Last modified 3 years ago

Safari v4+ paste from keyboard broken in fckeditor 2.6.5

Reported by: kamelkev Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6.5
Keywords: Safari Cc:

Description

Attempting to cut and paste into an fckeditor 2.6.5 pane fails.

Paste will appear for an extremely brief period time (milliseconds), and then be cleared. Other content within the fckeditor pane will remain unchanged.

Essentially a paste acts as a no-op.

This appears to be recent as I did not observe this behaviour on 2.6.4

<I am particularly familiar with the necessary categorization of this ticket, if someone could move it to a better place that would be appreciated. There have been complaints regarding this issue since November on the forum.>

Change History

comment:1 Changed 5 years ago by kamelkev

This occurred on safari version 4.0.4 on a Mac. Other people have been reporting the issue for various versions of safari - but I can't say if it's on 3.x

comment:2 Changed 5 years ago by kamelkev

The section to be pasted must also include some type of styling (surrounding spans).

When style spans are used, the paste fails. Otherwise it seems to work correctly.

I have created a video of the problem, see it here:

http://blip.tv/play/AYG76w4C

comment:3 Changed 5 years ago by kamelkev

On 07/27/09 11:27:11 there was a commit made referencing: "Fixed #3481 : Fixed Fixed an issue in WebKit where paste actions inside table cells may leak outside of the table cell."

Prior to this fix, pasting worked fine. After this point, the pastes don't work correctly anymore...

comment:4 Changed 5 years ago by fredck

WFM with CKEditor 3.1.

For V2, you may consider removing the changes introduced with [3973] for now.

comment:5 Changed 5 years ago by fredck

  • Version set to FCKeditor 2.6.5

comment:6 Changed 5 years ago by alfonsoml

  • Keywords Confirmed Safari added

comment:7 follow-up: ↓ 8 Changed 5 years ago by dcaravana

I have the problem in CKEditor in 3.1 (was not in 3.02) only with option forcePasteAsPlainText set to true.

comment:8 in reply to: ↑ 7 Changed 5 years ago by fredck

Replying to dcaravana:

I have the problem in CKEditor in 3.1 (was not in 3.02) only with option forcePasteAsPlainText set to true.

I've opened a dedicated ticket for this issue: #4988.

comment:9 Changed 3 years ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to invalid

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

comment:10 Changed 3 years ago by kamelkev

The ticket was a duplicate, but whatever. The issue has long since been solved.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy