Ticket #4977 (closed Bug: fixed)

Opened 5 years ago

Last modified 3 years ago

[IE] After inserting Text and Table Template we can't go back and Type in the Template

Reported by: damo Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IBM Cc: JoeK

Description (last modified by fredck) (diff)

  1. Open the CK Editor.
  2. Enter some text.
  3. Click on Templates Icon.
  4. un check Replace actual contents check box
  5. Select the Text and Table Template.
  6. See that the Template is inserted.
  7. Click next to the text you have typed before and enter some more text.
  8. Try to go to the Title or the Text Field by Using Arrow Keys or Point it by using Mouse.

Actual result: we can't go to the Title Filed or Text Field to Type the Text ..The Only way we can do it..First Click on the Table in the Template and then Click next to the Title Field or Text Field. This is happening only in IE6 and IE7

Expected result: The Cursor should be next to the Title after we inserted the Template.This is what is happening in FF2 and FF3.

Browsers: IE6 and IE7

Change History

comment:1 Changed 5 years ago by fredck

  • Description modified (diff)

That's because we have a positioned element <div style="width: 80%"> and that's the way IE6/7 handle it, making them unusable. Fortunately it works with IE8 (a "bit" better, still not perfect though). There is very little we can do about it.

I'll leave it open for investigation.

comment:2 Changed 5 years ago by fredck

For reference, #4682 is all about it.

comment:3 Changed 4 years ago by fredck

  • Milestone CKEditor 3.x deleted

Milestone CKEditor 3.x deleted

comment:4 Changed 3 years ago by j.swiderski

  • Status changed from new to closed
  • Resolution set to fixed

This is no longer reproducible in latest CKEditor 3.6.3

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy