Ticket #499 (closed Bug: invalid)

Opened 8 years ago

Last modified 7 years ago

ColdFusion Image Handler in v2.4.2

Reported by: MarcRJacobs Owned by:
Priority: Normal Milestone:
Component: Server : ColdFusion Version: FCKeditor 2.4.2
Keywords: Cc:

Description

I am using FCKeditor v2.4.2 with CF MX 7.0.1 on Linux. Everything is configurated and working well with sample02_mx.cfm, except image upload. My folders are set up as /home/admin/sites/fckeditor, and fckeditor is my baseurl. When I upload an image it creates a new folder called "siteImages" right off /home/admin. It then uploads the file correctly, and you can select it, but it doesn't return with the image, just a red "x". It doesn't matter how I set <cfset Application.userFilesPath = "/userfiles/"> or <cfset application.FCKeditor.userFilesPath = "/userfiles/">, and yes they are "cflocked", and these variables do in fact get set properly. I am certain the error is NOT in my reading the docs, but rather, somewhere in the connector. Many other posts here seem to indicate other similar problems in older versions with the image pathing. I tried the v2.4 connector.cfm, as well as a mod recommended by vash20 on 2007-01-19. No luck with either. I have also done a search through all the code I could for "siteImages", no luck there either. Please help....

Change History

comment:1 Changed 8 years ago by MarcRJacobs

Additional Note: I did try using php for _FileBrowserLanguage and _QuickUploadLanguage, using the ColdFusion frontend. The image portion worked perfect, but would not return it to sample02_mx.cfm. Do you have any other ideas???

comment:2 Changed 8 years ago by fredck

  • Keywords Image removed

Please use our forums for discussions:
http://sourceforge.net/forum/forum.php?forum_id=257180

comment:3 follow-up: ↓ 4 Changed 8 years ago by fredck

  • Status changed from new to closed
  • Resolution set to invalid

If you still confirm you have a bug, please reopen this ticket with more precise information about it. You may also use "editor/filemanager/browser/default/connectors/test.html" to help you understand any configuration problem.

If you are just looking for help, again, please use the forums.

comment:4 in reply to: ↑ 3 Changed 8 years ago by MarcRJacobs

  • Status changed from closed to reopened
  • Resolution invalid deleted

Replying to fredck:

If you still confirm you have a bug, please reopen this ticket with more precise information about it. You may also use "editor/filemanager/browser/default/connectors/test.html" to help you understand any configuration problem.

If you are just looking for help, again, please use the forums.

comment:5 Changed 8 years ago by fredck

  • Keywords Pending added

Please give us more details regarding the bug so we can try to reproduce it here.

comment:6 Changed 8 years ago by MarcRJacobs

I am not sure what more information to provide you with. I have a development server running CentOS and CFMX 7. My website root for Apache is /home/admin/sites, I created a folder /home/admin/sites/fckeditor_test, and extracted all of v2.4.2. I followed the wiki "ColdFusion Integration" to the letter.

<!--- Application.cfm ---> <html> <!--- Establish Application Frame And Client Management ---> <cfapplication name = "FCKeditor"

clientmanagement = "No" setclientcookies = "Yes" sessionmanagement = "Yes" sessiontimeout = "#createtimespan(0, 2, 0, 0)#" applicationtimeout = "#createtimespan(0, 2, 0, 0)#" setdomaincookies = "No"

<cfset request.FCKeditor = StructNew()> <cfset request.FCKeditor.userFilesPath = "/fckeditor_test/userfiles/"> </html>

fckconfig.js var _FileBrowserLanguage = 'cfm'; var _QuickUploadLanguage = 'cfm';

config.enabled = true; in both config.cfm under filemanager

Everything works except image management. With configurations as shown above my images are uploaded successfully to /home/admin/sitesImage. Then, of course, they shown up as a red x in the viewer, because it is pointing to the place I specified in Application.cfm.

I hope this is clearer.

Thank you for your consideration.

comment:7 Changed 8 years ago by fredck

  • Keywords Pending removed

Can you confirm if #510 fixes it?

comment:8 Changed 8 years ago by MarcRJacobs

Sorry, unfortunately it has not. I just spent the last four hours with it. I got a few non-descript java errors, worked them out, and finally got to the point where it consistently threw permission errors. I have checked all permissions on the linux development server, and they are fine. I really don't know where else to look. Also, I am on v2.4.2, whereas the person in ticket 510 is on 2.4.3. Any help would be very much appreciated. I am really enjoying this product, and would like to be able to add image capability.

comment:9 Changed 8 years ago by alfonsoml

Have you tried setting "serverPath"?

from config.cfm:

config.serverPath = ""; use this to force the server path if FCKeditor is not running directly off the root of the application or the FCKeditor directory in the URL is a virtual directory or a symbolic link / junction

comment:10 Changed 8 years ago by MarcRJacobs

Ok, I think I might have some useful information for you now.
On my server, my test version is v2.4.2 and is located at /home/admin/sites/fckeditor_test/
In config.cfm I set config.serverPath = "/home/admin/sites/fckeditor_test/userfiles/";
In Application.cfm, I set:
<cfset request.FCKeditor = StructNew()>
<cfset request.FCKeditor.userFilesPath = "/marcfiles/">

When I clicked on the "Insert/Edit Image" icon, the "Image Properties" dialog opened fine. I clicked "Browse Server", the "Resources Browser" opened, and immediately the server created /home/admin/sites/fckeditor_test/userfiles/Image/
Continuing, I clicked "Browse", and selected a picture from my local computer. It was called "pc122323.jpg". I clicked "Upload", and the file was successfully placed in the empty "Image" folder previously created. I then clicked on the picture to return to the "Image Properties" dialog. The picture did not show in the preview window, only a red "X". The reason why is that the URL is set to /marcfiles/Image/pc122323.jpg
This is where our problems appear. Do I still have a setting wrong somewhere?

comment:11 Changed 8 years ago by alfonsoml

is "/home/admin/sites/fckeditor_test/userfiles/" the physical path to "/marcfiles/" ?

As you can see the files are being uploaded there, so you must just put in that setting where do you want the files to be placed.

comment:12 Changed 8 years ago by MarcRJacobs

I'm sorry, I don't really understand your question. My intent was to use /home/admin/sites/fckeditor_test/userfiles/ as the starting point to place the user's images. Then, using Application.cfm, point them at another sub-folder called /marcfiles/ underneath /home/admin/sites/fckeditor_test/userfiles/. The purpose of the test was to ultimately replace /marcfiles/ with something like /#session.loginname#/.

comment:13 Changed 7 years ago by alfonsoml

  • Status changed from reopened to closed
  • Resolution set to invalid

If serverPath is used it must contain the physical path to the userFilesPath.

Setting them to diffent elements of course will lead to troubles.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy