Ticket #4992 (closed Bug: fixed)

Opened 5 years ago

Last modified 4 years ago

Empty <style> tags in fullPage mode

Reported by: larsinsd Owned by:
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Spell Checker Version: 3.1
Keywords: Confirmed Cc: SpellChecker.net

Description

When in fullPage mode, CKEditor 3.1 puts empty <style> tags in the <head> section.

Attachments

ckeditor-fullpage-style-bug.jpg (63.5 KB) - added by larsinsd 5 years ago.
screenshot of empty style tags

Change History

comment:1 Changed 5 years ago by alfonsoml

  • Keywords Pending added

The fullPage.html sample works fine for me in Firefox 3.5, IE8, Opera 10.10 and Safari 4

What are the steps to reproduce the problem?

Changed 5 years ago by larsinsd

screenshot of empty style tags

comment:2 Changed 5 years ago by larsinsd

This is the HTML that is first loaded into the editor:

<html><head></head><body><p>Write your email message here.</p> <p>You can also import any saved email or one of our professional templates using the "Template" button above.</p></body></html>

The empty <style> tags are automatically added to the HTML source (no modification has been done) to the editor content.

More empty <style> tags appear with use - if I change font color, it will add 2 more. If I change font color again, I get 2 more.

comment:3 Changed 5 years ago by alfonsoml

I've stated the file that I've used for the tests and the browsers that I tested. They all worked fine.

I've tested your sample and I don't see any problem:

<html>
	<head>
	</head>
	<body>
		<p>
			Write your email message here.</p>
		<p>
			You can also import any saved <span style="color: rgb(178, 34, 34);">email </span>or one of our <span style="background-color: rgb(218, 165, 32);">professional </span>templates using the &quot;Template&quot; button above.</p>
	</body>
</html>

comment:4 Changed 5 years ago by larsinsd

Ok - I found the problem. It's with SCAYT.

scayt_autoStartup : true

Will cause all those problems with the empty <style> elements. Not sure if that's something you want to fix now or not, but for now, I've disabled it on my editor.

comment:5 Changed 5 years ago by alfonsoml

  • Keywords Confirmed added; Pending removed
  • Cc SpellChecker.net added
  • Component changed from General to UI : Spell Checker

Correct, each time that the content is loaded it adds two <style> to the head of the document. And sometimes also adds a class to the body (depending whether it's enabled or not):

	<body class="scayt-disabled">

comment:6 Changed 5 years ago by larsinsd

That would appear to be a "feature" with SCAYT... so I'll keep it disabled for now.

BTW, thank you for all the hard work you guys are doing. Your editor is awesome.

comment:7 Changed 5 years ago by fredck

  • Milestone set to CKEditor 3.3

comment:8 Changed 4 years ago by garry.yao

I would ask SpellChecker.net to perform proper cleanup in scayt.destroy(), restoring the DOM to what exactly it was.

comment:9 Changed 4 years ago by fredck

  • Status changed from new to closed
  • Resolution set to fixed

It would be enough to mark the style elements with the cke_temp="1" attribute. But I'm not able to reproduce it anymore on trunk, so I think it has already been fixed.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy