Ticket #5134 (closed Bug: duplicate)

Opened 5 years ago

Last modified 7 months ago

"Paste From Word" control showing error while pasting bullet list from MS Word.

Reported by: pranav Owned by:
Priority: Normal Milestone: CKEditor 3.3
Component: Plugin : Paste from Word Version: 3.1
Keywords: Oracle Cc: Senthil, Pranav

Description

"Paste From Word" control display follwoing error while pasting bullet list from MS Word:

"It was not possible to clean up the pasted data due to an internal error."

The issue was reproducible in Internet Explorer 8 and Firefox 3.6. Please refer to attached image for more error details.

Attachments

PasteFromWord.png (22.4 KB) - added by pranav 5 years ago.
"Paste From Word" Error
Sample.doc (19.5 KB) - added by pranav 5 years ago.
Sample Word File

Change History

Changed 5 years ago by pranav

"Paste From Word" Error

comment:1 follow-up: ↓ 2 Changed 5 years ago by fredck

  • Keywords Pending added

This may be related to a specific HTML structure coming from Word. Can you please provide us a sample Word doc that raises this error?

Changed 5 years ago by pranav

Sample Word File

comment:2 in reply to: ↑ 1 Changed 5 years ago by pranav

Replying to fredck:

This may be related to a specific HTML structure coming from Word. Can you please provide us a sample Word doc that raises this error?

I have added the sample word file with this ticket.

comment:3 follow-up: ↓ 5 Changed 5 years ago by alfonsoml

It's working fine for me. Maybe it depends on the version of MS Word or its configuration.

comment:4 Changed 5 years ago by fredck

  • Keywords Pending removed
  • Milestone set to CKEditor 3.3

Let's investigate it further.

comment:5 in reply to: ↑ 3 Changed 5 years ago by pranav

Replying to alfonsoml:

It's working fine for me. Maybe it depends on the version of MS Word or its configuration.

I have attached a zip file of ckeditor where you can reproduce the issue in IE8. The URL for the same is http://rapidshare.com/files/357813409/ckeditor.zip.html

Please varify and let us know.

comment:6 Changed 5 years ago by pranav

This problem us happening only in our code line of CKEditor 3.1 at revision #5018. Since this problem is not reproducible in nightly build, please provide a patch in our codeline. You can reproduce the problem using the attached ckeditor zip file above.

comment:7 follow-up: ↓ 8 Changed 5 years ago by garry.yao

  • Status changed from new to closed
  • Resolution set to duplicate

This problem us happening only in our code line of CKEditor 3.1 at revision #5018

I guess you're not intended to point to that reversion.
Anyway this's duplicate of #4683, if you're using a reversion that has this bug, you can safely apply the patch at #4683 to resolve it.

comment:8 in reply to: ↑ 7 Changed 5 years ago by pranav

Replying to garry.yao:

This problem us happening only in our code line of CKEditor 3.1 at revision #5018

I guess you're not intended to point to that reversion.
Anyway this's duplicate of #4683, if you're using a reversion that has this bug, you can safely apply the patch at #4683 to resolve it.

Since we uptook the CKEditor at revision #5018, patch #4683 is already applied. I have varified this manually. But still the problem is happening. Can you please provide the appropriate patch for this issue?

comment:9 Changed 4 years ago by garry.yao

Since we uptook the CKEditor at revision #5018...

#5018 is a opened ticket number instead of a SVN reversion number, [5018] is a valid reversion number but not a trunk version.

patch #4683 is already applied

The #4683 was fixed at reversion [5028], so it happens after [5018].

But still the problem is happening

I've verified 4683.patch applied on your attached ckeditor zip file (not sure why the file is deleted without any comment) resolves the problem.

comment:10 Changed 7 months ago by fredck

  • Component changed from Core : Pasting to Plugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy