Ticket #5283 (closed Bug: duplicate)

Opened 5 years ago

Last modified 4 years ago

CKEDITOR.config.baseHref not working properly on IE8

Reported by: Kassel1975 Owned by:
Priority: Normal Milestone:
Component: General Version: 3.2.1
Keywords: Pending Cc:

Description

I use a relative path to the images. When I upload or integrate a picture via server browsing everything is allright. the picture is shown. BUT when I press the source code button to see the source code and then switch back again to wysiwyg modus the editor can't find the picture agin and shows a mistake.

Attachments

error1.gif (13.9 KB) - added by Kassel1975 5 years ago.
pic before pressing the source code button
error2.gif (9.7 KB) - added by Kassel1975 5 years ago.
source code button pressed
error3.gif (3.5 KB) - added by Kassel1975 5 years ago.
error after changing back to wysiwyg mode

Change History

Changed 5 years ago by Kassel1975

pic before pressing the source code button

Changed 5 years ago by Kassel1975

source code button pressed

Changed 5 years ago by Kassel1975

error after changing back to wysiwyg mode

comment:1 Changed 5 years ago by alfonsoml

  • Milestone CKEditor 3.3 deleted

comment:2 in reply to: ↑ description Changed 5 years ago by Kassel1975

I use IE Version: 8.0.6001.18702

comment:3 Changed 5 years ago by martin.rossland

  • Version changed from 3.2 to 3.2.1

I can confirm this bug.

I've got the same problem running CKEditor in IE quirks mode.

I'll be very grateful if someone could apply a temporary workaround for this particularly problem!

Thanks in advance!

comment:4 Changed 5 years ago by martin.rossland

I guess this is the same problem, but in my case switching from source mode to wysiwyg mode, CKEditor appends a base path on urls. This is strange since my basehref configuration is blanc. Have also tried to set a dummy basehref, but still the base path is appended.

Example: <a href="testing">testing</a> is replaced by <a href="http://mydomain.com/testing">testing</a>

comment:5 Changed 5 years ago by martin.rossland

Please ignore the two previous comments.

In my case, the mode switching problem was actually caused by a bug in one of my own plugins. But this is still a problem on copy/paste (ref. ticket #5218).

Sorry!

comment:6 Changed 4 years ago by Kassel1975

I'll be very grateful if someone could apply a temporary workaround for this particularly problem!

comment:7 Changed 4 years ago by alfonsoml

  • Keywords Pending added

Can you provide a simple test page to reproduce the problem?

comment:8 Changed 4 years ago by Kassel1975

  • Version changed from 3.2.1 to 3.3

the same problem is discribed in ticket: https://dev.fckeditor.net/ticket/5042

comment:9 Changed 4 years ago by alfonsoml

  • Status changed from new to closed
  • Version changed from 3.3 to 3.2.1
  • Resolution set to duplicate

dup of #5042

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy