Ticket #5466 (closed Bug: fixed)

Opened 5 years ago

Last modified 5 years ago

SCAYT interferes on color commands

Reported by: fredck Owned by:
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Spell Checker Version: SVN (CKEditor) - OLD
Keywords: Confirmed Cc: SpellChecker.net

Description

  1. Load the following:
<p>ThisAA isAA someAA textAA.</p>
  1. Enable SCAYT and wait for it to highlight all words.
  1. Hit CTRL+A to select all.
  1. Apply a background color.
  1. Check the Source code.

Note that a separated <span> tag has been created for every space and word in the text.

Change History

comment:1 follow-up: ↓ 2 Changed 5 years ago by SpellChecker.net

We are able to reproduce the problem on nightly build, but not able to reproduce it in CKEditor 3.2.

Can also reproduce it with following text even without enabling SCAYT

<p>This is some <strong>sample text</strong>. You are using <a href="http://www.fckeditor.net/">FCKeditor</a>.</p>

So it seems it that the problem is actual for any markup, not only SCAYT's

comment:2 in reply to: ↑ 1 Changed 5 years ago by fredck

Replying to SpellChecker.net:

We have made improvements to the color commands, and these now get applied on text nodes only. The results we have with the input you've provided are expected. Note that you don't have a span for every word, but for every text node.

The problem is that with SCAYT, its temporary tags are not part of the output, which makes the broken spans senseless.

We need to change things here in a way that SCAYT tags will not break the color spans.

comment:3 Changed 5 years ago by SpellChecker.net

The problem is clear (SCAYT needs to work with textnodes too) - SCAYT should to join same markup during removing its tags. So seems that with new behavior of color commands the poblem is similar or even dub of #4836.

comment:4 Changed 5 years ago by SpellChecker.net

The patch which resolves the #4836 "SCAYT - when enabled, text formatting is working differently" is expected to resolve #5466 "SCAYT interferes on color commands"

For the FF the patch resolves the problem in situation described in ticket, but for IE it does not. It seems that it is not SCAYT specific.

There is a situation with CK markup when CK does not merge siblings

  1. Type three words: asdf asfd asdf
  2. mark first two words as any markup - markup #1 (e.g. strong)
  3. mark second two words with some other markup - markup #2 (e.g. background color)
  4. select second word and remove markup #1 from second word (i.e. click Bold button)
  5. switch to Source

IE produces following output: <p>

<strong>asdf </strong><span style="background-color: #ffd700">asdf</span><span style="background-color: #ffd700"> asdf</span></p>

In the FF the problem cannot be reproduced. FF produces following output: <p>

<strong>asdf </strong><span style="background-color: rgb(255, 140, 0);">asdf asdf</span></p>

One more note: if the second markup is <a>, then siblings are not merged in both IE and FF, producing following output: <p>

<strong>asdf </strong><a href="http://asdf">asfd</a><a href="http://asdf"> asdf</a></p>

One more question on link (<a>):

  1. Type three words: asdf asfd asdf
  2. mark first two words as any markup - markup #1 (e.g. strong)
  3. mark second two words with link

Try to edit link or unlink (using context menu) - there are two links, not the one as end user may expect. Is it correct behavior?

Are the improvement to color commands (sticking to textNodes) are specific for background coloring only? Do you plan to spread these improvements to other types of markup? Why are you decided to stick to textNodes? Is there some problems you are resolving by such solutions (some bugs you are fixing) - if possible we would like to know?

The reason why we are asking is that improvement affects SCAYT - SCAYT underline style is overridden by background style of CK color markup. We have no solution for the problem yet. Actually SCAYT prefers to stick to textNode as the CK do in the background markup.

comment:5 Changed 5 years ago by garry.yao

There is a situation with CK markup when CK does not merge siblings... Try to edit link or unlink (using context menu) - there are two links, not the one as end user may expect...

Confirming these two are bugs, for which I've opened #5567.

Is there some problems you are resolving by such solutions (some bugs you are fixing) - if >possible we would like to know?

It's because of #3599, and for now it's used only for Background Color style while later we might get introduced to other styles, I understand the problem it has brought to SCAYT now, while it's not a problem dedicate to our changes, we have this problem in previous version when apply bgcolor partially on any misspelled word.

comment:6 Changed 5 years ago by garry.yao

  • Status changed from new to closed
  • Resolution set to fixed

Confirmed to be fixed by #5567 and #4836.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy