Ticket #5554 (closed Bug: fixed)

Opened 5 years ago

Last modified 3 years ago

forcePasteAsPlainText can't be set in config file

Reported by: advseb Owned by:
Priority: Normal Milestone:
Component: General Version: 3.2.1
Keywords: Cc:

Description

I'm using CKEditor inside Drupal with the ckeditor module. I want to add the following line to the config file:

config.forcePasteAsPlainText=true;

I debugged the execution of the config js file with Firebug on Firefox 3.6. The structure/class "config" doesn't have a member 'forcePasteAsPlainText'. Therefore, my setting is ignored.

I also added the above line to the config.js file inside ckeditor distribution, but without any effect. Please note, it might be that config.js is never executed due to the Drupal integration. Still, all other settings in the official config file used by the ckeditor module of drupal work.

Change History

comment:1 Changed 5 years ago by advseb

It might be that the issue described above is caused by a bug in the Drupal ckeditor module. Please see:

http://drupal.org/node/703428#comment-2866586

comment:2 Changed 4 years ago by garry.yao

  • Keywords Pending added; forcePasteAsPlainText removed

WFM on trunk.

comment:3 Changed 3 years ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to fixed

Works fine under latest CKEditor 3.6.2.

Also I have asked colleague to check it under drupal - problem doesn't seem to occur there also. Setting (in configuration panel) option "Force pasting as plain text:" for particular instance works as expected.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy