Ticket #5625 (closed Bug: expired)

Opened 4 years ago

Last modified 4 years ago

Focus arbitrarily jumping between editors

Reported by: pavelgj Owned by:
Priority: High Milestone:
Component: UI : Spell Checker Version: 3.2.1
Keywords: Pending Cc: SpellChecker.net

Description

In IE8, when scayt_autoStartup:true and multiple editors on the same page, once you switch to the next editor (tab or click) cursor (focus) starts arbitrarily jumping between the editors while you type. It doesn't happen when scayt is disabled.

How to reproduce:

  1. Edit ckeditor\_samples\replacebycode.html and add {scayt_autoStartup: true} to the replace(...) for both editors (editor1 and editor2).
  2. Open replacebycode.html in IE8, click on the first editor and type something.
  3. Press tab to switch to the next editor and continue typing (might take a few dozen characters)

Observed result: cursor jumps randomly between the two editors. This observation is fairly consistent and should be easy to reproduce.

Change History

comment:1 Changed 4 years ago by pavelgj

Further analysis:

It looks like the focus is switched (forced back) when SpellChecker.net AJAX call is returned in the editor. So, if you don't wait for the SpellChecker.net to return the results and switch to the next editor (typing fast and switching between editors quickly), the focus is forced back to the previous editor once the results are returned.

comment:2 Changed 4 years ago by garry.yao

  • Keywords Pending added; spellchecker removed

There's recent updates happened at SCAYT, now WFM in IE, could you please verify again?

comment:3 Changed 4 years ago by pavelgj

I'm testing the nightly build right now. At a first glance the issue doesn't seem to be happening anymore. I'll do more testing throughout the day and let you know. Thank you.

comment:4 Changed 4 years ago by garry.yao

  • Status changed from new to closed
  • Resolution set to expired
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy