Ticket #5780 (closed Bug: fixed)

Opened 4 years ago

Last modified 3 years ago

Text selection disappears when open the link dialog

Reported by: Issy Owned by: garry.yao
Priority: High Milestone: CKEditor 3.3.1
Component: UI : Dialogs Version: 3.3
Keywords: Confirmed Firefox Safari Review+ Cc: aren@…

Description

I select a text to make a link. Then I open the link dialog and the mark usually disappears. This is a link displayed in the editor, instead of the selected text is linked. I have the problem with Firefox 3.6. You can check this on the CKEditor demo page.

Attachments

5780.patch (886 bytes) - added by garry.yao 4 years ago.

Change History

comment:1 Changed 4 years ago by alfonsoml

  • Keywords Confirmed added; link, selection, dialog removed
  • Milestone changed from CKEditor 3.3 to CKEditor 3.4

Confirmed with Firefox. With IE it shows an error an error the first time and then it also inserts the link text.

comment:2 Changed 4 years ago by garry.yao

  • Keywords Firefox added

Providing a cleaner way to reproduce:

Environment

Firefox

Reproducing Procedures

  1. Open the 'replacebyclass' sample page, make the following selection;
    <p>
    	This is s[om]e <strong>sample text</strong>. You are using <a href="http://ckeditor.com/">CKEditor</a>.</p>
    
  2. Click on 'Link' button to open dialog;
    • Actual Result: The grey mark on document is lost which indicate the selection is lost in editor.

comment:3 Changed 4 years ago by garry.yao

  • Status changed from new to assigned
  • Owner set to garry.yao

Changed 4 years ago by garry.yao

comment:4 Changed 4 years ago by garry.yao

  • Keywords Safari Review? added

range::getEnclosedNode is no longer DOM destructive thus no longer breaks text selection.

comment:5 Changed 4 years ago by garry.yao

  • Priority changed from Normal to High

comment:6 Changed 4 years ago by fredck

  • Milestone changed from CKEditor 3.4 to CKEditor 3.3.1

comment:7 Changed 4 years ago by fredck

#5764 as been marked as DUP.

comment:8 Changed 4 years ago by arencambre

  • Cc aren@… added

comment:9 Changed 4 years ago by alfonsoml

#5792 has been marked as dup

comment:10 Changed 4 years ago by alfonsoml

  • Keywords Review+ added; Review? removed

comment:11 Changed 4 years ago by garry.yao

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed with [5558] with design tests update.

comment:12 follow-up: ↓ 13 Changed 4 years ago by MikeVrind

  • Status changed from closed to reopened
  • Resolution fixed deleted

Just uploaded the updated version of CKeditor and the bug is still there in FF3.6.3.

When I select a text to make it clickable, the url apears next to the text.

(cleared cache etc)

comment:13 in reply to: ↑ 12 Changed 4 years ago by MikeVrind

Replying to MikeVrind:

Just uploaded the updated version of CKeditor and the bug is still there in FF3.6.3.

When I select a text to make it clickable, the url apears next to the text.

(cleared cache etc)

Sorry, bug also present in IE8 and Chrome 5.0.375

comment:14 Changed 4 years ago by fredck

I'm not able to reproduce it. Do you have this issue in our online demo? can you provide the precise steps to reproduce it?

comment:15 Changed 4 years ago by virtual

Yes, issues are still happening in the online demo. It's reproducible in all browsers I try (Chrome 5, Chrome 6dev, Firefox 3.6, IE7, IE8, Safari 4..).

It is sporadic. Highlight text, enter in URL, press Ok and it inserts the hyperlink as the URL you typed (e.g. <a href="http://google.com">google.com</a>. As I said, it is sporadic, so it may take 1 try or it may take 10.

comment:16 Changed 4 years ago by alfonsoml

I've tried for about 5 minutes to make it fail with Firefox 3.6 and IE8 and all the times it has worked correctly.

comment:17 Changed 4 years ago by fredck

  • Status changed from reopened to closed
  • Resolution set to fixed

In any case, please do not reopen this ticket for this issue, as it's closed and committed aready. Please open a new one if you have more information about it.

comment:18 Changed 3 years ago by syn4k

This is also happening to me. Every single time I select some text, it becomes unleslected when using the paragraph formatting dropdown, changing text to a link, etc.

Firefox 3.6.17, 3.6.18 on CKEditor version: 3.54.

Here is a demo showing you how link button is breaking: http://screencast.com/t/lvyePQDI9A

Here is a demo showing you how the paragraph formatting dropdown is breaking: http://screencast.com/t/wBo3O7aoj

Last edited 3 years ago by syn4k (previous) (diff)

comment:19 Changed 3 years ago by syn4k

I noticed that edits to the ticket do not get emailed, so please note that I have provided demonstration links in the above message.

comment:20 Changed 3 years ago by syn4k

Can we please reopen this ticket?

comment:21 Changed 3 years ago by wwalc

@syn4k - please feel free to create a new ticket with your findings. This issue has been fixed once in milestone CKEditor 3.3.1, using the attached patch, so reopening this ticket would just cause a mess.

comment:22 Changed 3 years ago by syn4k

Thank you. I have done this at http://dev.ckeditor.com/ticket/8160

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy