Opened 6 years ago

Closed 6 years ago

#5829 closed Bug (fixed)

Start Values for Roman & Alpha Numbered Types are not working

Reported by: satya Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.4
Component: General Version: 3.3
Keywords: IBM Confirmed Review+ Cc: damo, joek

Description

To reproduce the defect:

  1. Open Ajax Sample and create a Numbered list.
  1. select the Numbered list and select the Numbered List Properties in the Context menu.
  1. In the Numbered list type select Upper Alpha(A,B,C,D,E,etc) and in the Start filed Enter D
  1. Click OK button.

Expected Result: Numbered list Type changes to Upper Alpha Type and the list Starts with D

Actual Result: Numbered list Type changes to Upper Alpha Type but the list Starts with A and when you open the Numbered List Properties dialog again you will see the Start Value as D

Same behaviour happens with Lower Alpha,Upper & Lower Roman Numbered list types.

Attachments (1)

5829.patch (1023 bytes) - added by garry.yao 6 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 6 years ago by fredck

  • Keywords Confirmed added

The thing here is that the value for the start must be a number (remember it's a "numbered" list). So, in the provided TC, the user should type "4", not "D", on that field.

This is something that we can't (and shouldn't) change. Otherwise we would start requiring the user to type roman or greek numbers there, which may get confusing. Other than that, the code implementation to support it would be quite huge and complex, considering all the numbering types we have.

I'm leaving this ticket open because we should at least have a proper validation in the field, showing a warning to the user if the value for that field is not a number.

Changed 6 years ago by garry.yao

comment:2 Changed 6 years ago by garry.yao

  • Keywords Review? added
  • Owner set to garry.yao
  • Status changed from new to assigned

comment:3 Changed 6 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:4 Changed 6 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [5640].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy