Ticket #5849 (closed Bug: fixed)

Opened 5 years ago

Last modified 2 years ago

Inserting Images in IE7

Reported by: shill Owned by:
Priority: Normal Milestone:
Component: General Version: 3.3.1
Keywords: Cc: mail@…

Description

Using IE7, if you delete an image in a document, don't move the cursor and then insert a new image, it places the new image at the top of the doc.

Infact, it seems as though as soon as you select "Upload Image" it resets the cursor to the top of the document so any image that is inserted in IE7 always appears at the top of the document

All worked fine in CKEditor 3.2 (revision 5205)

Change History

comment:1 Changed 4 years ago by Juergen

I can confirm this (also IE 7). But i need to append some issues to this ticket:

If working with window.open-dialogs, editor.insertElement() and insertHtml() of that diaglog will place the inserted element also at the top of the document.

In a ck-internal dialog, that will not happen. I guess that's a focus issue, but editor.focus() before inserting doesn't work.

That's how we insert the elemenents in the modal window:

    var CKEDITOR = (dialogArguments  ? dialogArguments : window.opener).CKEDITOR;
    var editor = CKEDITOR.instances.editor1;

    function insert(src) {
        var makeElement = function( name ){ return new CKEDITOR.dom.element( name, editor.document ); };
        var img = makeElement('img');
        img.setAttribute('src', src);

        editor.insertElement(img);

        window.close();
    }

Just a sidenode: that doesn't just affect images, all elements inserted in ie7 from a external window is placed at top of document instead of the current position.

Worked in 3.2 and all other browsers (FF, Chrome, IE 8) except IE 7.

With best regards, Juergen

comment:2 Changed 4 years ago by Juergen

  • Cc mail@… added

comment:3 Changed 2 years ago by j.swiderski

  • Status changed from new to closed
  • Resolution set to fixed

I was not able to reproduce any of the above issues in latest CKE 3.6.4

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy