Opened 5 years ago

Closed 5 years ago

#5868 closed Bug (wontfix)

Turning bullets on and off adds new lines to the text

Reported by: tzweteto Owned by:
Priority: Normal Milestone:
Component: Core : Lists Version:
Keywords: Cc:


When text is marked as list, and then unmarked, extra new lines added to the first text. The reason for that is that <p> tags are added after removing the bullets.

Steps to reproduce:

  1. Open latest CK Editor build
  2. Click Source
  3. Paste the text:

<p>line1<br />line2</p>

  1. Click on "Source" button again to turn it off.
  2. You see that your text is displayed as two lines with no line between them.
  3. Mark the two lines and click on "Insert/Remove bullet list" button -> the two lines are displayed in bullet list now
  4. Select the text again and click "Insert/Remove bullet list" to remove the bullets -> the two lines are displayed again, but with new line between them. The reason for that is that instead of <br />, <p> tags are created in the source.

Please check the attached screenshots.

Attachments (1)

bullets_ck_editor.JPG (183.5 KB) - added by tzweteto 5 years ago.

Download all attachments as: .zip

Change History (2)

Changed 5 years ago by tzweteto

comment:1 Changed 5 years ago by fredck

  • Resolution set to wontfix
  • Status changed from new to closed

The reason behind this is quite simple: there is no way for us to understand if a list was originally text separated by BRs or separated paragraphs. So, we just take the generic case, converting it to paragraphs. There is no way for us to change this, because there is no ideal solution for that.

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy