Ticket #5869 (closed Bug: fixed)

Opened 4 years ago

Last modified 17 months ago

Content in editing area overflow to edges of editor

Reported by: mbaroz Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version: 3.3.1
Keywords: IE Cc: tech@…

Description

Hi Using IE 8 / Win 7 CKEditor 3.3.1 , after opening editor via JS API and having text which fills the height of editing area the text is overflowing the edges / frame of the editor (attached is a snapshot)

Also the editor behaves very slow and stuck the browser . These issues are not in the previous version(3.2.1)

Attachments

ckeditor_err_1.JPG (69.5 KB) - added by mbaroz 4 years ago.
Snapshot of the issue behavior
ck_content.txt (2.0 KB) - added by mbaroz 4 years ago.
ckeditor_err_en.JPG (69.1 KB) - added by mbaroz 4 years ago.

Change History

Changed 4 years ago by mbaroz

Snapshot of the issue behavior

comment:1 Changed 4 years ago by fredck

  • Priority changed from High to Normal
  • Keywords WorksForMe added; text overflow , IE problem removed
  • Component changed from UI : Dialogs to General
  • Milestone CKEditor 3.x deleted

That's strange, because the scroolbar shows precisely that the contents should not overflow. It's definitely a browser bug.

I'm not able to reproduce it here in any way though. I see you have the problem with the Hebrew interface. Do you have the same with English?

Can you attach a sample test page with the editor, that can be used to check the problem, as well as a document with the contents to be set in the source mode so we're able to reproduce it?

comment:2 Changed 4 years ago by mbaroz

Hi Again and thank you for response. The problem is the same in english (i attached a snapshot).

i have attached a document with the SRC of the content..

What you need as a sample page ? you mean entering the edit mode on my page ?

Thanks Moshe

Changed 4 years ago by mbaroz

Changed 4 years ago by mbaroz

comment:3 Changed 4 years ago by Saare

  • Keywords IE added; WorksForMe removed
  • Component changed from General to UI : Spell Checker

I'm actually identifying this bug as a IE SCAYT-realted bug.

Steps to reproduce

  • Open the AJAX sample in IE.
  • Quickly type a misspelled word long enough to create a scrollbar, pressing the letter 'a' in the keyboard for a long time does the trick.
  • Wait for SCAYT to mark the word.
  • Scroll using the scrollbars to the edges of the content, notice that the text gets out of the editor's chrome.
  • Put the caret inside the word again and move with the keyboard arrows. Notice that the scrollbar is moving, each time to the opposite side.

Both LTR and RTL contents directions are affected.

comment:4 Changed 4 years ago by SpellChecker.net

  • Keywords IE, Pending added; IE removed

We are unable to reproduce this bug even with CKEditor 3.3.1. Can you confirm that you still have this problem?

comment:5 Changed 4 years ago by SpellChecker.net

  • Cc tech@… added

comment:6 Changed 4 years ago by Saare

  • Keywords IE added; IE, Pending removed
  • Status changed from new to confirmed

I can still confirm that using the steps mentioned in comment:3 with IE8 and the nightly build.

comment:7 Changed 4 years ago by SpellChecker.net

The SpellChecker.net team still can't reproduce this bug using instruction from comment #3. We were trying to reproduce it with the latest CKeditor nightly build in IE 8.0.7600.16385 under Windows7. We were trying English. In our case text doesn't get out of the editor's chrome. Scrollbar wasn't moving on pressing arrow keys.

comment:8 Changed 4 years ago by SpellChecker.net

  • Version changed from 3.3.1 to 3.4.2 (SVN - trunk)

We still can't reproduce the problem. Do you reproduce it at http://nightly.ckeditor.com/5952/_samples/ajax.html ? Maybe there any other ways to reproduce the bug? Any sample code or specific configuration?

comment:9 Changed 4 years ago by alfonsoml

  • Version changed from 3.4.2 (SVN - trunk) to 3.3.1

comment:10 Changed 17 months ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to fixed

I have checked TC from comment:3 in IE8 in latest CKEditor 3.6.6 and 4.1.1 and wasn't able to reproduce this issue. I'm closing it as fixed.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy