Ticket #5985 (closed Bug: worksforme)

Opened 4 years ago

Last modified 4 years ago

tables: adding column before a cell that's been merged to the right will create another tdspan=2 cell in new column.

Reported by: Jude Allred Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description (last modified by krst) (diff)

repro steps:

  1. go to http://ckeditor.com/demo using firefox.
  2. click inside the "Italian" cell of the table
  3. Merge that cell to the right. We now have a "ItalianCappuccetto Rosso" cell.
  4. Right click in that cell and insert a column 'before'
  5. [bug] the new colomn on the left has a tdspan of 2, and the table is borked:
<table align="right" border="1" cellpadding="1" cellspacing="1" style="width: 200px;">
	<caption>
		<strong>International Names</strong></caption>
	<tbody>
		<tr>
			<td>
				&nbsp;</td>
			<td>
				Chinese</td>
			<td>
				<i>小紅帽</i></td>
		</tr>
		<tr>
			<td colspan="2">
				&nbsp;</td>
			<td colspan="2">
				Italian<i>Cappuccetto Rosso</i></td>
		</tr>
		<tr>
			<td>
				&nbsp;</td>
			<td>
				Spanish</td>
			<td>
				<i>Caperucita Roja</i></td>
		</tr>
	</tbody>
</table>

The expected output is:

<table align="right" border="1" cellpadding="1" cellspacing="1" style="width: 200px;">
	<caption>
		<strong>International Names</strong></caption>
	<tbody>
		<tr>
			<td>
				&nbsp;</td>
			<td>
				Chinese</td>
			<td>
				<i>小紅帽</i></td>
		</tr>
		<tr>
			<td>
				&nbsp;</td>
			<td colspan="2">
				Italian<i>Cappuccetto Rosso</i></td>
		</tr>
		<tr>
			<td>
				&nbsp;</td>
			<td>
				Spanish</td>
			<td>
				<i>Caperucita Roja</i></td>
		</tr>
	</tbody>
</table>

Or, in more-english-than-not, the cell created is improperly receiving the attribute 'colspan="2"'. Removing that attribute restores order to the universe.

Change History

comment:1 Changed 4 years ago by krst

  • Status changed from new to closed
  • Resolution set to worksforme
  • Description modified (diff)

Works For Me on Firefox 2.0.20 &CKE 3.4.1 , Also Chrome7, IE9

<table align="right" border="1" cellpadding="1" cellspacing="1" style="width: 200px;">
	<caption>
		<strong>International Names</strong></caption>
	<tbody>
		<tr>
			<td>
				&nbsp;</td>
			<td>
				Chinese</td>
			<td>
				<i>小紅帽</i></td>
		</tr>
		<tr>
			<td colspan="2">
				&nbsp;</td>
			<td colspan="2">
				Italian<i>Cappuccetto Rosso</i></td>
		</tr>
		<tr>
			<td>
				&nbsp;</td>
			<td>
				Spanish</td>
			<td>
				<i>Caperucita Roja</i></td>
		</tr>
	</tbody>
</table>

comment:2 Changed 4 years ago by Jude Allred

I just reproduced this in IE9 and Firefox using the steps above, and judging by your 'works for me' snippet, you also found the bug. (I can tell by the colspans.)

Please revisit this.

I'll restate this problem:

starting point of table: [][] [][] [][]

table, post merge: [][] [ ] [][]

table, post-insert-column-before [][][] [ ][] [][][]

expected: [][][] [][ ] [][][]

comment:3 Changed 4 years ago by Jude Allred

agh, newlines not respected...

Again, thats:

starting point of table: 
[][]
[][]
[][] 

table, post merge: 
[][]
[  ]
[][] 

table, post-insert-column-before
[][][]
[  ][]
[][][] 

expected: 
[][][]
[][  ]
[][][]
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy