Ticket #6112 (closed Bug: fixed)

Opened 4 years ago

Last modified 4 years ago

BIDI: Alignment set to text in Table cell is not shown in the Tool bar when we press Enter to start a new Paragraph

Reported by: satya Owned by: tobiasz.cudnik
Priority: Normal Milestone: CKEditor 3.4.1
Component: General Version: 3.4 Beta
Keywords: IBM Cc: damo,joek

Description

To reproduce the defect:

  1. Open Ajax sample.
  1. Insert a Table, go in to a Table cell, and click on an Alignment option(for eg: Align Right) in the Tool bar.
  1. Now Type the text in the cell and see that it is Right Aligned and Align Right icon in the Tool bar is highlighted.
  1. Press Enter.

Expected Result:

A New Paragraph starts and it should have Right Alignment as well and Align Right Icon in the Tool bar should be highlighted.

Actual Result:

A New Paragraph is started and it has Right Alignment but Align Right Icon in the Tool bar is not showing as highlighted and when we keep the cursor in the previous paragraph Align Right icon is not even highlighted for that Paragraph as well.

same behavior happens for all the Alignment options.

Attachments

6112.patch (964 bytes) - added by tobiasz.cudnik 4 years ago.
6112_2.patch (970 bytes) - added by tobiasz.cudnik 4 years ago.

Change History

comment:1 follow-ups: ↓ 2 ↓ 3 Changed 4 years ago by tobiasz.cudnik

  • Keywords Pending added

I can't reproduce it, Alignment icon always represents correct state. Here's the content i've used:

<table>
	<tbody>
		<tr>
			<td style="text-align: right;">
				<p>
					foo</p>
				<p>
					bar</p>
			</td>
		</tr>
	</tbody>
</table>

On what browser you're experiencing this issue ?

comment:2 in reply to: ↑ 1 Changed 4 years ago by satya

Replying to tobiasz.cudnik:

I can't reproduce it, Alignment icon always represents correct state. Here's the content i've used:

<table>
	<tbody>
		<tr>
			<td style="text-align: right;">
				<p>
					foo</p>
				<p>
					bar</p>
			</td>
		</tr>
	</tbody>
</table>

On what browser you're experiencing this issue ?

I could reproduce it on all the browsers FF3.5,IE6 & 7..even though <td style="text-align: right;"> is shown in HTML source for the Table cell, the corresponding icon(Align Right)is not shown as highlighted in the Tool bar when we keep the cursor in the paragraph.

comment:3 in reply to: ↑ 1 ; follow-up: ↓ 4 Changed 4 years ago by satya

Replying to tobiasz.cudnik:

I can't reproduce it, Alignment icon always represents correct state. Here's the content i've used:

<table>
	<tbody>
		<tr>
			<td style="text-align: right;">
				<p>
					foo</p>
				<p>
					bar</p>
			</td>
		</tr>
	</tbody>
</table>

On what browser you're experiencing this issue ?

It might be useful to mention that this issue occurs when config.useComputedState = false;

comment:4 in reply to: ↑ 3 Changed 4 years ago by fredck

  • Status changed from new to confirmed
  • Keywords Pending removed

Replying to satya:

It might be useful to mention that this issue occurs when config.useComputedState = false;

Yes, that changes everything.

comment:5 Changed 4 years ago by fredck

  • Milestone set to CKEditor 3.4.1

comment:6 Changed 4 years ago by tobiasz.cudnik

  • Status changed from confirmed to assigned
  • Owner set to tobiasz.cudnik

Changed 4 years ago by tobiasz.cudnik

comment:7 Changed 4 years ago by tobiasz.cudnik

  • Status changed from assigned to review

comment:8 Changed 4 years ago by Saare

  • Status changed from review to review_failed

On L40 you should use getAttribute() and hot hasAttribute(). Also, please add || '' after it to avoid having a null value.

Changed 4 years ago by tobiasz.cudnik

comment:9 Changed 4 years ago by tobiasz.cudnik

  • Status changed from review_failed to review

comment:10 Changed 4 years ago by Saare

  • Status changed from review to review_passed

comment:11 Changed 4 years ago by tobiasz.cudnik

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [5856].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy