Opened 6 years ago

Closed 3 years ago

#6153 closed Bug (fixed)

Chrome: tab focus is wrong.

Reported by: admini Owned by:
Priority: Normal Milestone:
Component: General Version: 3.3
Keywords: WebKit Cc:

Description

I am using the last version of CKEditor (also checked nightly build). When using Chrome (last), user pressed "tab" from text input into CKEditor, and the whole gray frame became "focused" style. I tried to press on keyboard but no response. using mouse worked.

Attachments (3)

6153.patch (1.2 KB) - added by tobiasz.cudnik 6 years ago.
6153_2.patch (1.2 KB) - added by tobiasz.cudnik 6 years ago.
6153.html (3.0 KB) - added by Saare 6 years ago.

Download all attachments as: .zip

Change History (33)

comment:1 Changed 6 years ago by Saare

  • Keywords Webkit added
  • Milestone set to CKEditor 3.4.1
  • Status changed from new to confirmed
  • Version changed from 3.4.1 (SVN - trunk) to 3.3

Supposed to be fixed by #6154.

comment:2 Changed 6 years ago by tobiasz.cudnik

  • Owner set to tobiasz.cudnik
  • Status changed from confirmed to assigned

#6154 is related strictly to Opera and no other browser should be affected by it or the reason #6154 exists (which is #6025).

comment:3 Changed 6 years ago by tobiasz.cudnik

  • Owner tobiasz.cudnik deleted
  • Status changed from assigned to new

This issue doesn't seem to be fixable, we have to find some workaround.

comment:4 Changed 6 years ago by tobiasz.cudnik

  • Owner set to tobiasz.cudnik
  • Status changed from new to assigned

Fixable by 6192.patch from #6192.

Changed 6 years ago by tobiasz.cudnik

comment:5 Changed 6 years ago by tobiasz.cudnik

  • Status changed from assigned to review

This is fixed version of 6192.patch dedicated for TC of this ticket.

comment:6 Changed 6 years ago by tobiasz.cudnik

  • Status changed from review to assigned

This patch is accident duplicate of 6178.patch, please go to #6178.

Changed 6 years ago by tobiasz.cudnik

comment:7 Changed 6 years ago by tobiasz.cudnik

  • Status changed from assigned to review

Changed 6 years ago by Saare

comment:8 Changed 6 years ago by Saare

  • Status changed from review to review_failed

The patch didn't resolve the issue for me. I'm attaching the TC I'm using.

comment:9 Changed 6 years ago by tobiasz.cudnik

  • Status changed from review_failed to review

It turned out to be a cache related issue.

comment:10 Changed 6 years ago by Saare

  • Status changed from review to review_passed

Ugh.. Chrome's cache :/
Works great, sorry about that.

comment:11 Changed 6 years ago by tobiasz.cudnik

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [5899].

comment:12 Changed 6 years ago by tobiasz.cudnik

Commited into correct branch with [5907].

comment:13 Changed 6 years ago by krst

On Safari 5/Mac tab switching on attached html with empty text box and two editors works wrong:

  • focus set on textbox, hit tab
  • focus set on first editor, blinking cursor, no text entering is possible
  • hit tab
  • focus set on second editor, blinking cursor, no text entering is possible
  • hit tab, so the focus is back to the textbox
  • hit tab - focus is set on editor, entering is not possible
  • hit tab second time - now it is possible to enter text into editor
  • second editor - same thing

comment:14 Changed 6 years ago by tobiasz.cudnik

  • Resolution fixed deleted
  • Status changed from closed to reopened

Confirming, reduced TC:

  1. Open a sample with the editor.
  2. Hit Tab key to get into the editing area.
  3. Try to type some chars.

comment:15 Changed 6 years ago by tobiasz.cudnik

  • Owner tobiasz.cudnik deleted
  • Status changed from reopened to new

comment:16 Changed 6 years ago by tobiasz.cudnik

  • Status changed from new to confirmed

Seems someone had reverted [5907].

comment:17 Changed 6 years ago by tobiasz.cudnik

  • Owner set to tobiasz.cudnik
  • Status changed from confirmed to assigned

comment:18 Changed 6 years ago by wwalc

  • Milestone changed from CKEditor 3.4.2 to CKEditor 3.4.3

Postponing to 3.4.3 as fixing it asap could introduce more unknown issues.

comment:19 Changed 6 years ago by garry.yao

I still dunno why this ticket is reopened.

comment:20 Changed 6 years ago by garry.yao

  • Status changed from assigned to pending

[5907] is not partially reverted, precisely the part that not related to the ticket. Can anyone confirm this a Mac OS issue? WFM in both Chrome/Safari on Windows.

comment:21 Changed 6 years ago by tobiasz.cudnik

  • Status changed from pending to confirmed

We had already confirmed (1, 2) that this is an issue on Macosx, using Safari5.

However, it's not related to partially reverted [5907].

comment:22 Changed 6 years ago by fredck

  • Keywords WebKit added; Webkit removed
  • Milestone changed from CKEditor 3.4.3 to CKEditor 3.5.1

Is it related to a WebKit bug? Do you have a ticket at their side for it?

comment:23 Changed 6 years ago by tobiasz.cudnik

Since #6192 i can't create a reduced TC for this issue and i think it's related to our complex focus logic. Thus, we don't have a ticket for this issue, although we can point them to some of our samples, but i don't know if it's appropriate.

comment:24 Changed 6 years ago by garry.yao

#6296 is marked as a DUP.

comment:25 Changed 6 years ago by wwalc

  • Milestone changed from CKEditor 3.5.1 to CKEditor 3.5.2

comment:26 Changed 5 years ago by fredck

I did some research, by testing the replacebycode sample.

"TAB and type" was used to work well with the 3.2.2.

It stopped working properly with the 3.3. "Typing" was working only on the first editor.

The culprit for the issue, at that release is [5509], a changeset with no ticket or review :/

Then with the 3.3.2 things got worst... no "typing" at all.

It never worked well since then, and the behavior changed a bit on the following releases.

comment:27 Changed 5 years ago by fredck

  • Owner tobiasz.cudnik deleted
  • Status changed from confirmed to new

comment:28 Changed 5 years ago by fredck

  • Status changed from new to confirmed

comment:29 Changed 5 years ago by wwalc

  • Milestone CKEditor 3.5.3 deleted

comment:30 Changed 3 years ago by j.swiderski

  • Resolution set to fixed
  • Status changed from confirmed to closed

Problem is no longer reproducible in CKE 4.2.2.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy