Ticket #6193 (closed Bug: fixed)

Opened 4 years ago

Last modified 21 months ago

IE8: Ctrl+a -> ctrl+c -> ctrl+v alters links and inserts a newline.

Reported by: Jude Allred Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IE Cc:

Description (last modified by tobiasz.cudnik) (diff)

  1. set editor source to
    <p>
    	<a class="wikiNew" href="default.asp?W2648">i am a link</a></p>
    <p>
    	i am a paragraph</p>
    
  2. edit in wysiwyg mode using ie8
  3. hit ctrl+a, ctrl+c, ctrl+v
  4. expected: no change actual: 'i am a paragraph' is now a link and there's a fresh newline up top.

Attachments

nicer.PNG (11.9 KB) - added by Jude Allred 4 years ago.
(Here's the same bug report, but formatted more pleasantly)
repro.avi (371.0 KB) - added by Jude Allred 4 years ago.
Video of the repro against ckeditor.com/demo

Change History

Changed 4 years ago by Jude Allred

(Here's the same bug report, but formatted more pleasantly)

comment:1 Changed 4 years ago by tobiasz.cudnik

  • Description modified (diff)

comment:2 Changed 4 years ago by tobiasz.cudnik

  • Keywords IE added

I cannot reproduce it. Do you have this error on our demo page also ?

comment:3 Changed 4 years ago by tobiasz.cudnik

  • Status changed from new to pending

comment:4 Changed 4 years ago by Jude Allred

Repro'd against ckeditor.com/demo using the steps above.

I'll attach a video.

Changed 4 years ago by Jude Allred

Video of the repro against ckeditor.com/demo

comment:5 Changed 21 months ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to fixed

Extra paragraphs were reported in different tickets already. As for the linking it is no longer reproducible in latest CKEditor 3.6.4

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy