Ticket #6212 (closed Bug: fixed)

Opened 4 years ago

Last modified 3 years ago

Chrome resize jumps to top of page

Reported by: tigris Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.2
Component: General Version: 3.4
Keywords: WebKit Cc: EricFromCanada

Description

This bug is reproducible on the stock demo.

If you enter lots of content, and make the editor bigger than your browser, so scroll bars appear on the outer document, then scroll down on your page, when you resize the editor the scroll will jump back to the top. This makes it unusable if your editor is at the bottom of a large document.

This only happens in webkit browsers such as chrome/safari.

If you revert changset:5516 the bug disappears, but I'm sure it was there for a reason, so not sure what bug will reappear?

Attachments

6212.patch (4.2 KB) - added by garry.yao 3 years ago.
6212_2.patch (938 bytes) - added by garry.yao 3 years ago.

Change History

comment:1 Changed 4 years ago by tobiasz.cudnik

  • Status changed from new to closed
  • Resolution set to duplicate

DUP of #6195.

comment:2 Changed 4 years ago by tigris

Leave closed if you like, but I believe this bug is completely separate from ticket:6195 as it refers to the elementspath plugin not wrapping correctly.

This bug I have mentioned for above is introduced many times throughout trying to fix together hacks in ticket:5729 and ticket:6195 and is specific to the resizing of the editor.

comment:3 Changed 3 years ago by EricFromCanada

  • Cc EricFromCanada added
  • Version changed from 3.4 to 3.4.3

This is still a problem in 3.4.3 and 3.5, and can still be seen in the demo. Using either Chrome or Safari on Mac or Windows,

  • load http://ckeditor.com/demo in a window short enough to cause the scrollbar to appear
  • scroll to the bottom of the window
  • attempt to resize the editor

and note how the page scrolls up suddenly. In some cases the window will scroll up only slightly; in others it will jump to the top of the page. This does not occur in IE or Gecko-based browsers.

comment:4 Changed 3 years ago by tech.lawson

If you manually revert changeset:5516 it fixes the problem - and with the latest version of Safari, the following doesn't apply at all:

Resize the width first. WEBKIT BUG: Webkit requires that we put the editor off from display when we resize it. If we don't, the browser crashes!

comment:5 Changed 3 years ago by wwalc

  • Status changed from closed to reopened
  • Keywords Webkit added; webkit chrome resize removed
  • Resolution duplicate deleted

#6195 looks like a separate issue for me. The initial description of that thicket has nothing to do with this one.

Confirmed that it is a regression caused by [5516].

comment:6 Changed 3 years ago by wwalc

  • Status changed from reopened to confirmed

comment:7 Changed 3 years ago by EricFromCanada

  • Keywords resize added
  • Version changed from 3.4.3 to 3.6.2 (SVN - trunk)

comment:8 Changed 3 years ago by wwalc

  • Keywords WebKit added; Webkit resize removed
  • Version changed from 3.6.2 (SVN - trunk) to 3.4

@EricFromCanada The version field should be set to the oldest version where issue is reproducible, see TicketSpecs for more details.

Changed 3 years ago by garry.yao

comment:9 Changed 3 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from confirmed to review

comment:10 Changed 3 years ago by garry.yao

Patch also tries to tackle #3601 while preserving #5729.

comment:11 Changed 3 years ago by Saare

  • Status changed from review to review_failed

Resizing in Safari scrolls the host page, not to top though, just above the editor.

comment:12 Changed 3 years ago by garry.yao

  • Status changed from review_failed to review

Manual tc added with [7120]. @Saar can't reproduce the issue you mentioned.

Changed 3 years ago by garry.yao

comment:13 Changed 3 years ago by garry.yao

#5729 is not anymore reproducible for me after 6212_2, so it looks like the concern in [5516] has expired, see if the reviewer can confirm this too.

comment:14 Changed 3 years ago by fredck

  • Status changed from review to review_passed
  • Milestone set to CKEditor 3.6.2

It seems that we have no crashing issues any more without that code. Cool!

comment:15 Changed 3 years ago by j.swiderski

This issue may have been duplicated in #8272. I'm not sure here because #8272 still does not work.

comment:16 Changed 3 years ago by garry.yao

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [7213].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy