Opened 6 years ago

Closed 5 years ago

#6247 closed Bug (fixed)

Focus not returning to editor on drop down close

Reported by: satya Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.6.1
Component: UI : Floating Panel Version: 3.4
Keywords: IBM Cc: damo, joek

Description (last modified by garry.yao)

To reproduce the defect:

  1. Open Ajax sample.
  1. Type some text,keep the cursor in the text,click on any of the drop down lists(Styles,Paragraph Format,Font Name,Font Size,Text Color & Background Color) to show list items.
  1. Click on the same drop down to make the list disappear.(don't select any of the list items).
  • Actual Result: The editor has not got focus.Try to type some text and it see it won't get typed.

Attachments (3)

krst 10.50.26 .avi (60.5 KB) - added by krst 6 years ago.
6247.patch (1.7 KB) - added by garry.yao 5 years ago.
6247_2.patch (2.5 KB) - added by garry.yao 5 years ago.

Download all attachments as: .zip

Change History (18)

comment:1 in reply to: ↑ description Changed 6 years ago by krst

  • Keywords IE added
  • Status changed from new to confirmed
  • Version set to 3.4

Replying to satya:

First Error:

Cursor is shown in the drop down list

Confirmed

  1. Click on the same drop down to make the list disappear.(don't select any of the list items).

Second Error:

Cursor is visible in the editor but the editor has not got focus. Try to type some text and it see it won't get typed.

Confirmed. Second opened list - Cursor is disabled.

Changed 6 years ago by krst

comment:2 Changed 6 years ago by mani

  • Owner set to mani
  • Status changed from confirmed to assigned

comment:3 Changed 6 years ago by krst

Second part of the ticket is moved to #6345

comment:4 Changed 6 years ago by mani

I looking for solution to resolve first error and I find out that set focus on panel (in this situation drop down list) works good but there is problem because you must catch every click event and check if drop down list is open and set focus on them so I think that is not good solution but resolve problem.

If this could be help the #5667 cause the problem.

comment:5 Changed 6 years ago by mani

  • Owner mani deleted
  • Status changed from assigned to new

comment:6 Changed 6 years ago by garry.yao

  • Keywords IE removed
  • Priority changed from Normal to Low
  • Status changed from new to confirmed

This's a generic problem, the focus was trapped inside the closed panel ;(

comment:7 Changed 6 years ago by garry.yao

Some other misbehaved TCs that I think tightly related to this:

  1. Open the default sample page with FF;
  2. Click inside editor to give focus;
  3. Open the styles combo by mouse click;
  4. Press 'Esc' key to close the combo;
  • Expected Result: Panel closed with focus return to editor;
  • Actual Result: Focus return to toolbar.

The above TC though is surprisingly work in IE though.

In a summary, what need to do here:

  1. Where to return focus depending on from where combo is opened;
    • Return focus to toolbar in condition of "toolbarMode";
    • Return focus to editor otherwise;
  2. "Esc" and button click must behave consistently following 1.
  3. 1 and 2 must apply to other panel based drop down.

comment:8 Changed 6 years ago by garry.yao

  • Description modified (diff)
  • Summary changed from [[IE]] Cursor is still visible in the editor after the editor loses focus. to [[IE]] Focus not returning to editor on drop down close

comment:9 Changed 6 years ago by garry.yao

  • Description modified (diff)
  • Summary changed from [[IE]] Focus not returning to editor on drop down close to Focus not returning to editor on drop down close

Description cleanup.

Changed 5 years ago by garry.yao

comment:10 Changed 5 years ago by garry.yao

  • Cc changed from damo,joek to damo, joek
  • Component changed from General to UI : Floating Panel
  • Owner set to garry.yao
  • Status changed from confirmed to review

comment:11 Changed 5 years ago by fredck

  • Priority changed from Low to Normal
  • Status changed from review to review_failed

Still not working for Safari and Opera.

Changed 5 years ago by garry.yao

comment:12 Changed 5 years ago by garry.yao

  • Status changed from review_failed to review

Add Safari and Opera compatibility.

comment:13 Changed 5 years ago by fredck

  • Status changed from review to review_passed

comment:14 Changed 5 years ago by fredck

  • Milestone set to CKEditor 3.6.1

comment:15 Changed 5 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [6920].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy