Ticket #6275 (closed Bug: fixed)

Opened 4 years ago

Last modified 3 years ago

insert <embed> and custom attributes in other tags failed in Firefox 3.6.9

Reported by: PC Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Firefox Cc:

Description

example:

oEditor.insertHTML('<embed src="http://www.youtube.com/v/ZZxx3VmTq3M?fs=1" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="480" height="385"></embed>');

but oEditor.getData() returns

<img align="" alt="Flash" src="../images/spacer.gif?t=A7HG4HT" style="width: 480px; height: 385px;" />

only happens in FF3.6.9

Change History

comment:1 Changed 4 years ago by awstin

It's a bug in insertHtml() method. I've tried also via firebug to insert an object in the demo from youtube with the function insertHtml() and it's stripping all tag properties like "_cke_realelement" containing object infos from the img placeholder.

comment:2 Changed 4 years ago by douglasandre

I'm also having the same problem, please help me! I am using CKeditor version 3.2 and some users complained that the insertion of videos was buggy. I found the problem and performed tests with version 3.4 which showed the same problem on mozila firefox >= 3.6.9

comment:3 Changed 4 years ago by rocing

I'm also having the same problem, please help me!

comment:4 Changed 4 years ago by labbejf

The src attribute of the img tag is also modified to a relative path.... I received a lot of complaint from our client.... Please help

comment:5 Changed 4 years ago by alfonsoml

  • Status changed from new to confirmed
  • Keywords Firefox added
  • Summary changed from insert <embed> failed in Firefox 3.6.9 to insert <embed> and custom attributes in other tags failed in Firefox 3.6.9

This is due to a security change in Firefox, and it's affecting all the editors that use the inserthml command. https://bugzilla.mozilla.org/show_bug.cgi?id=596300

comment:6 Changed 4 years ago by alfonsoml

#6288 has been marked as dup

comment:7 Changed 4 years ago by alfonsoml

#6280 and #6321 have been marked as dups

comment:8 Changed 4 years ago by alfonsoml

#6325 has been marked as dup

comment:9 follow-up: ↓ 10 Changed 4 years ago by abushnell

This has become a major issue for our clients who use a WYSIWYG in a CMS. Any timeframe for this fix?

comment:10 in reply to: ↑ 9 Changed 4 years ago by Saare

Replying to abushnell:

This has become a major issue for our clients who use a WYSIWYG in a CMS. Any timeframe for this fix?

This is not up to us. This is a FF bug.

comment:11 Changed 4 years ago by Saare

#6364 has been marked as dup

comment:12 Changed 4 years ago by alfonsoml

Mozilla has published beta builds of Firefox 3.6.11 that includes the fixes for these problems: ftp://ftp.mozilla.org/pub/firefox/nightly/3.6.11-candidates/build2/

Anyone interested should test them before they are released and published for everybody.

comment:13 follow-up: ↓ 15 Changed 4 years ago by joelstein

Firefox 3.6.11 was released yesterday, and it appears to have fixed this problem.

comment:14 Changed 3 years ago by alfonsoml

#6631 has been marked as dup

comment:15 in reply to: ↑ 13 Changed 3 years ago by garry.yao

  • Status changed from confirmed to closed
  • Resolution set to fixed

Replying to joelstein:

Firefox 3.6.11 was released yesterday, and it appears to have fixed this problem.

Confirmed.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy