Ticket #6511 (closed Bug: fixed)

Opened 4 years ago

Last modified 4 years ago

[IE8] '0.startContainer' is null or not an object

Reported by: SpellChecker.net Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version: 3.4.1
Keywords: IE, Oracle Cc: tech@…, naresh.sivaraman

Description

Steps to reproduce:

  1. Open ckeditor.com/demo page in IE8
  2. Enable SCAYT
  3. Input button from CKEditor's toolbar
  4. Right-click on input button

Actual result:
Context menu is not displayed and error is shown:
Message: '0.startContainer' is null or not an object
Line: 119
Char: 1903
Code: 0
URI: http://ckeditor.com/apps/ckeditor/3.4.1/ckeditor.js?1288073785[[BR]]

Expected result:
Context menu is displayed with no errors

Attachments

6511.patch (664 bytes) - added by SpellChecker.net 4 years ago.

Change History

Changed 4 years ago by SpellChecker.net

comment:1 Changed 4 years ago by SpellChecker.net

Here we propose patch that fixe this issue.

comment:2 Changed 4 years ago by garry.yao

  • Keywords IE added; IE8, HasPatch, Review? removed
  • Status changed from new to confirmed

Waiting to be checked after #6735.

comment:3 Changed 4 years ago by wwalc

  • Keywords Oracle added

#6723 was marked as dup.

comment:4 Changed 4 years ago by garry.yao

  • Status changed from confirmed to pending

WFM on trunk, are you still able to reproduce it?

comment:5 Changed 4 years ago by SpellChecker.net

  • Keywords IE, Oracle, Confirmed added; IE Oracle removed

We can still see this behavior on trunk. After applying the patch, bug becomes fixed.

comment:6 Changed 4 years ago by SpellChecker.net

Sorry, one moment here. It can't be obeserved with "button", but can be still observed with "text field"

comment:7 Changed 4 years ago by wwalc

  • Cc naresh.sivaraman added

WFM as well in IE8 using CKEditor 3.5.2, I used the following source:

<form action="bar" name="foo">
	Sample text field: <input name="name" type="text" value="value" />&nbsp;</form>
<p>
	Mistyped wiord</p>

and the context menu showed up properly (SCAYT was enabled, I've tried also a button).

Could you provide the list of steps to reproduce it?

comment:8 Changed 4 years ago by SpellChecker.net

  • Keywords Pending added; Confirmed removed

It is fixed now. We can't reproduce it anymore.

comment:9 Changed 4 years ago by garry.yao

  • Status changed from pending to closed
  • Keywords Oracle added; Oracle, Pending removed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy