Opened 6 years ago

Closed 6 years ago

#6569 closed Bug (fixed)

Indentation doesn't honor text direction in list

Reported by: garry.yao Owned by: Saare
Priority: Normal Milestone: CKEditor 3.4.3
Component: Core : Lists Version: 3.4
Keywords: Cc:

Description

  1. Load the following content and selection:
    <ol>
    	<li dir="rtl" style="border: 1px solid">
    			^right to left
    	</li>
    </ol>
    
  2. Click on "Increase Indent";
    • Actual Result: Left-margin style is applied;
    • Expected Result: Right-margin should be applied.

Attachments (1)

6569.patch (2.8 KB) - added by Saare 6 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 6 years ago by tobiasz.cudnik

  • Owner set to tobiasz.cudnik
  • Status changed from new to assigned

comment:2 Changed 6 years ago by tobiasz.cudnik

  • Status changed from assigned to pending

This not a regression since 3.4.1, actually it's a result of [5307] from #3893, which introduces the design decision described as "Indent the entire list if cursor is inside the first list item".

Any propositions how to match those two ?

comment:3 Changed 6 years ago by garry.yao

Any propositions how to match those two ?

Yes, it should be ok after #6485.

Changed 6 years ago by Saare

comment:4 Changed 6 years ago by Saare

  • Milestone changed from CKEditor 3.4.2 to CKEditor 3.4.3
  • Owner changed from tobiasz.cudnik to Saare
  • Status changed from pending to review

The way I see it, we should respect the direction of the first item only if it's the only item there.
Not a regression, so I'm targeting it to the next release.

comment:5 Changed 6 years ago by garry.yao

  • Status changed from review to review_failed

The idea is ok, while for me we should only touch "getIndentCssProperty" function now.

comment:6 Changed 6 years ago by Saare

  • Status changed from review_failed to review

The approach of my patch saves us some lines and redundant traveling of the DOM.

comment:7 Changed 6 years ago by garry.yao

  • Status changed from review to review_passed

comment:8 Changed 6 years ago by Saare

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [6052].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy