Opened 5 years ago

Closed 5 years ago

#6625 closed Bug (fixed)

BIDI: Mixed LRT/RLT direction causes incorrect behaviour

Reported by: paho Owned by: tobiasz.cudnik
Priority: Normal Milestone: CKEditor 3.5.1
Component: Core : Lists Version: 3.4.1
Keywords: Cc:

Description

Paste source:

<ul dir="rtl">
	<li dir="ltr">
		item 1</li>
	<li>
		item 2</li>
</ul>

Incorrect behaviours:

  1. First item ('item 1') bullet icon is not visible in Opera, FF and Chrome.
  2. When you set focus on first item ('item 1') and decrease indent, it becomes RTL instead of remain as LTR.

Attachments (1)

6625.patch (758 bytes) - added by tobiasz.cudnik 5 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 5 years ago by krst

  • Component changed from General to Core : Lists
  • Status changed from new to confirmed
  • Version set to 3.0

Confirmed since CKE 3.0

comment:2 Changed 5 years ago by garry.yao

  • Milestone set to CKEditor 3.4.3
  • Version changed from 3.0 to 3.4.1

@Krst, "version" should only be used with absolute confidence.

  1. A browser bug, just like #6249;
  2. Caused by [5857], not a recent regression.

comment:3 Changed 5 years ago by fredck

  • Milestone changed from CKEditor 3.4.3 to CKEditor 3.5.1

comment:4 Changed 5 years ago by tobiasz.cudnik

  • Owner set to tobiasz.cudnik
  • Status changed from confirmed to assigned

Changed 5 years ago by tobiasz.cudnik

comment:5 Changed 5 years ago by tobiasz.cudnik

  • Status changed from assigned to review

Patch fixes the preservation of the direction on an outdented list item to a paragraph.

comment:6 Changed 5 years ago by garry.yao

  • Status changed from review to review_passed

comment:7 Changed 5 years ago by tobiasz.cudnik

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with [6255].

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy