Opened 6 years ago

Last modified 5 years ago

#6672 confirmed Bug

Cannot "cut" the form element on top of the page

Reported by: naresh.sivaraman Owned by:
Priority: Normal Milestone:
Component: Core : Selection Version: 3.0
Keywords: Oracle IE Cc:

Description

Issue seen in IE7.

To Reproduce:

  1. insert form element at the top of the page.
  1. click "Select All" to select all elements of the page
  1. then, click "Cut" icon --> all elements excepts the

form element is cut, but the form element remains.

Attachments (1)

ticket6672.odt (362.9 KB) - added by naresh.sivaraman 6 years ago.
Screenshots to reproduce issues.

Download all attachments as: .zip

Change History (18)

comment:1 Changed 6 years ago by naresh.sivaraman

Any updates on this bug please?

comment:2 Changed 6 years ago by wwalc

  • Keywords Oracle added

comment:3 Changed 6 years ago by krst

  • Component changed from General to Core : Selection
  • Keywords IE added
  • Status changed from new to confirmed
  • Version changed from 3.4.2 to 3.3

Confirmed for IE. Form element should be also Cut to clipboard, leaving an empty page.

Also other browsers have different behaviour on " Select All + Cut "

comment:4 Changed 6 years ago by krst

  • Keywords Chrome Opera added

Only Firefox leaves an empty page after "Select All + Cut" operation

comment:5 Changed 6 years ago by krst

  • Keywords IE Chrome Opera removed

comment:6 Changed 6 years ago by garry.yao

  • Keywords IE added
  • Resolution set to wontfix
  • Status changed from confirmed to closed

I don't think a fix could be provided at our side, the cut operation is a IE native browser behavior, also please note that Ctrl-X generally works fine.

comment:7 Changed 6 years ago by garry.yao

Note also the bug happens with a series of preconditions make it less remarkable:

  1. IE7 only
  2. With toolbar button (work with Ctrl-X)
  3. At the first clipboard inquiry only (confirm dialog)

comment:8 Changed 6 years ago by naresh.sivaraman

Garry,

It just does not stop with this scenario. The form is not cut on the first try with the toolbar button. Using the Cut button the second time does cut the form, but Paste does not paste the form.

Please look at the issue again and reopen the ticket.

I agree it works with Ctrl+X though.

comment:9 Changed 6 years ago by garry.yao

Paste works well for me in both ways, it's just a problem of CUT.

@naresh I'd be really happy to reopen if we could do anything that helps.

comment:10 Changed 6 years ago by fredck

  • Keywords CantFix added
  • Summary changed from CANNOT "CUT" THE FORM ELEMENT ON TOP OF THE PAGE to Cannot "cut" the form element on top of the page

comment:11 Changed 6 years ago by naresh.sivaraman

  • Keywords CantFix removed

Uploading a file with screenshots of steps to reproduce the two issues.

(1) Form is not cut the first time.(Using Cut toolbar button).

(2) Using the Cut button the second time does cut the form, but Paste does not paste the form.

Changed 6 years ago by naresh.sivaraman

Screenshots to reproduce issues.

comment:12 Changed 6 years ago by fredck

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:13 Changed 6 years ago by fredck

  • Milestone set to CKEditor 3.5.1
  • Resolution set to fixed
  • Status changed from reopened to closed

I've fixed the ticket TC with [6380].

Please note that the TC talks about cutting right after creating the form, so it's empty. If the forms has any content though, the issue appears again.

I've tried fixing it by changing the way the "select all" command works. I've create and selected a range that contains the entire <body> contents. It didn't work, because IE insists on "fixing" the selection to contain the <form> contents only. This is out of our control.

comment:14 Changed 5 years ago by naresh.sivaraman

Fredck,

Thanks for looking at the issue and providing the fix. I tested the fix with the CKEditor 3.5.1 on IE7 and found an issue. Have opened a new ticket(7160) for that since I could not reopen this.

Thanks

comment:15 Changed 5 years ago by j.swiderski

  • Milestone CKEditor 3.5.1 deleted
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version changed from 3.3 to 3.0
  1. Open ajax sample
  2. Insert form element at the top of the page.
  3. Click or use arrow down to go below form and type few characters
  4. Click "Select All" to select all elements of the page
  5. then, click "Cut" icon (when dialog shown click "Allow Access")

Form is not being cut.

TC reproducible from CKEditor 3.0 (till 3.2.1 I had to manually paste empty paragraph below form in source mode to reproduce) in all IE browsers

NOTE: If in STEP 5 you use CRTL+X form will be cut but if you use icon, press undo and then use CRTL+X then this shortcut will not work.

comment:16 Changed 5 years ago by j.swiderski

  • Status changed from reopened to confirmed

comment:17 Changed 5 years ago by j.swiderski

As you can see from the TC presented above there are problems when using "Cut" icon in IE.

This issue has its continuation in #7160.

Last edited 5 years ago by j.swiderski (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy