Opened 5 years ago

Closed 2 years ago

#7160 closed Bug (wontfix)

Cannot "paste" the form element on top of the page

Reported by: naresh.sivaraman Owned by: garry.yao
Priority: Normal Milestone:
Component: Core : Selection Version: 3.5.1
Keywords: Oracle IE6 IE7 Cc:

Description

Related to Ticket 6672 :

Tested the CKEditor 3.5.1 in IE7:

Found that the 'form' did get cut when using 'Cut' icon. But found that I could not use 'Paste' icon or Ctrl+v afterwards to paste the form. The form seems to be lost.

Attachments (2)

7160.patch (725 bytes) - added by garry.yao 5 years ago.
7160_2.patch (1.5 KB) - added by garry.yao 5 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 5 years ago by garry.yao

  • Status changed from new to confirmed
  • Version changed from 3.5.1 to 3.0

comment:2 Changed 5 years ago by wwalc

  • Keywords Oracle added

Changed 5 years ago by garry.yao

comment:3 Changed 5 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from confirmed to review

Applies to all IE versions.

comment:4 Changed 5 years ago by naresh.sivaraman

Garry,

The fix provided for http://dev.ckeditor.com/ticket/6672 does not seem to be fully fixing the issue.

(a) If the forms has any content though, the issue appears again. This has been mentioned by fredck himself. (b) After inserting an empty form, going to source and wysiwyg also makes the issue reappear.

Please let us know if these are not-fixable.

And I also tried taking up the patch provided here(and the one provided in 6672) and applying on my 3.4.2 CKEDITOR. I was still not able to paste. Please let me know how I can proceed.

comment:5 Changed 5 years ago by wwalc

  • Milestone set to CKEditor 3.5.3

comment:6 Changed 5 years ago by Saare

  • Status changed from review to review_failed

Patch does not fix the issue for me.

comment:7 Changed 5 years ago by fredck

  • Keywords IE added

This looks like an IE issue. I'm not sure it could ever be fixed.

comment:8 Changed 5 years ago by garry.yao

  • Resolution set to wontfix
  • Status changed from review_failed to closed

I can confirm also that the patch doesn't really help.

comment:9 Changed 5 years ago by fredck

  • Keywords CantFix added

comment:10 Changed 5 years ago by wwalc

  • Milestone CKEditor 3.5.3 deleted

Changed 5 years ago by garry.yao

comment:11 Changed 5 years ago by garry.yao

  • Keywords CantFix removed
  • Resolution wontfix deleted
  • Status changed from closed to reopened

Browser test shows that it's not her problem, so I decided to recheck all the suspicious code and have found it's partially caused by #5504 which I didn't manage to reproduce now on trunk. Another clue leads me to a flaw in the selection restoring logic we have right now also, so the bug is a combination of those two culprits.

comment:12 Changed 5 years ago by j.swiderski

  • Keywords IE6 IE7 added; IE removed
  • Status changed from reopened to confirmed
  • Version changed from 3.0 to 3.5.1

This issue is a continuation of #6672.

If the form is cut using "Cut" icon it gets lost and it can't be pasted anymore. Only "Undo" brings back the form.

NOTES:

  1. IMO issue has been reproducible only from CKE 3.5.1 when cutting with icon was enabled.
  2. I have managed to reproduce the issue only in IE6 and IE7

comment:13 Changed 2 years ago by Reinmar

  • Resolution set to wontfix
  • Status changed from confirmed to closed

It seems that it doesn't happen on any IE we currently support.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy