Ticket #672 (closed Bug: fixed)

Opened 7 years ago

Last modified 7 years ago

Extra lines inserted during save

Reported by: engelbmj@… Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: SF Cc: fredck

Description

The problem is pretty well documented in this thread:

http://sourceforge.net/forum/message.php?msg_id=3183737

When copying content into the editor from Word using the paste from Word feature, a "<p>&nbsp;</p>" is added after each line.


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1266563&group_id=75348&atid=543653

Change History

comment:1 Changed 7 years ago by martinkou

  • Cc fredck added
  • Reporter changed from martinkou to engelbmj@…

Fred,

Just one last comment. As you mentioned, the "<hr/>" tag is the problem. In fact, the position of this tag makes the document invalid (HTML 4.0). Removing the tag makes the document valid, and enables IE to parse it properly. I would argue that the problem is not with IE, but with the entity that produced the document (In my case, MS Word.).

  • Matt

Moved from SF. Original poster: engelbmj

Hello Matt,

I didn't post any report of it to Microsoft, also because they don't make it clear on were to post these things.

I'm know sure there is already a KB regarding it.

Let me know if you have something regarding it. Thanks in advance.

Best regards, FredCK


Moved from SF. Original poster: fredck

Fred,

Thanks for that concise description of the problem. As this is clearly a bug in IE, do you know if Microsoft is aware of the issue? Is there a link to a knowledge base article on their site that documents this problem? If not, I would like to make them aware of the problem.

  • Matt

Moved from SF. Original poster: engelbmj

The reported bug is a big issue that I've already investigated and sadly had the conclusion that it is almost impossible to solve. It is a problem that happens on every online editor available in the market and is strictly limited to IE.

The fact is that IE automatically changes the original HTML when parsing it and in some cases it seams that it looses the control and scramble it.

I was able to reproduce the problem with this very simple piece of HTML (inside the "---"):

<p><font color="#000000">First<hr/>Paragraph</font></p>
<p>Second Paragraph</p>

It seams that, in this case the problem is the HR tag in the middle of the paragraph.

When parsed by the editor, it is transformed on it:

<P><FONT color=#000000>First
<HR>
Paragraph</FONT>
<P></P>
<P>Second Paragraph</P>

So, as you can see, a new paragraph has been added to it. To clearly show the bug, just open the attached page on IE. You will see that the HTML shown in the alert dialog is completely different form the original in the body. So it is not a problem limited to the editing activation.

The only way to the editor to handle the actual contents of it when posting is by asking IE for it, looking at its DOM that reflects the modified source, not the original one. And IE gives back even worst results while navigating in the DOM tree. For example, it duplicates the "Paragraph" word that comes after the HR tag.

This seams to be just one case. I can't confirm that it is the only one because I'm sure that there would be other specific cases similar to this.

Unfortunately is notorious that IE has the better editing capabilities compared by other browsers, but has a terrible DOM parser. We are facing a serious browser and I can't see a clear way to find out a workaround to it.

If someone has any idea regarding it, please don't hesitate on contacting me.

Thanks in advance, FredCK


Moved from SF. Original poster: fredck

Please do NOT remove this record, I can confirm this is not just a MS Word issue.


Moved from SF. Original poster: Anonymous

Dear admin, please remove this bug record, as it seems this problem is with MS Word, and not with the editor.


Moved from SF. Original poster: engelbmj

comment:2 Changed 7 years ago by alfonsoml

  • Status changed from new to closed
  • Resolution set to fixed

This was fixed in #243

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy